cancel
Showing results for 
Search instead for 
Did you mean: 

oracle 9i on hp-ux 11i

Yoo, Jin-Seok
Occasional Contributor

oracle 9i on hp-ux 11i

I'v been tryingto install oracle 9i on hp-ux 11i
But i met ths following messages

$ Initializing Java Virtual Machine from /tmp/OraInstall2003-09-18_03-57-33PM/jre/bin/java. Please wait...
Exception in thread "main" java.lang.InternalError: Can't connect to X11 window server using '211.241.160.13:0.0' as the value of the DISPLAY variable.
at sun.awt.X11GraphicsEnvironment.initDisplay(Native Method)
at sun.awt.X11GraphicsEnvironment.(X11GraphicsEnvironment.java:63)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Unknown Source)
at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(GraphicsEnvironment.java:58)
at java.awt.Window.(Window.java:188)
at java.awt.Frame.(Frame.java:315)
at java.awt.Frame.(Frame.java:262)
at oracle.sysman.oii.oiic.OiicInstaller.main(OiicInstaller.java:593)

I Can't solve this problem.
I just guess the problem is Display setting.

How can I this problem..??

Please, Help me..!!
3 REPLIES
Mark Grant
Honored Contributor

Re: oracle 9i on hp-ux 11i

Looks like your display variable is not set correctly or clients are not allowed to access your display.

Set the DISPLAY variable to your workstations ip address with a :0 at the end for example

export DISPLAY=10.0.8.77:0

Also, it might be worth running "xhost +" on your X server if it isn't a PC running Reflections or Exceed or something.
Never preceed any demonstration with anything more predictive than "watch this"
T G Manikandan
Honored Contributor

Re: oracle 9i on hp-ux 11i

On the root prompt of the server just do a

#xhost +
to enable clients connecting this server.

On the other window if you have logged in as oracle

DISPLAY=:0.0
export DISPLAY

Just do a
$xclock
to check whether you get the display

Revert

Re: oracle 9i on hp-ux 11i

to my knowledge this is due to DISPALY problem.
If you use a another unix X system then you need to set your server's(oracle) DISPLAY=:0.0

after that then run xhost +

This should help you.

Please verify that the server's X system is up.

To get out of a difficulty, one usually must go through it