cancel
Showing results for 
Search instead for 
Did you mean: 

oracle patches

sh5490
Frequent Advisor

oracle patches

Hi,
We have install Rac on oracle 10.2.0.1 oracle version .As per oracle installation doc we need to install OS patches for hp ux version 1.23

PHSS_29655: aC++ Compiler (A.05.52)
PHSS_29656: HP C Compiler (A.05.52)
PHSS_29657: u2comp/be/plugin library Patch

Before installing we require to have

HP C/ANSI C Compiler (C.05.50):
C-ANSI-C
HP aC++ Compiler (C.05.50):
which is not installed on server.

Pls confirm if these patches are required for oracle Rac installation

Thanks
(Shabir)

7 REPLIES
Jupinder Bedi
Respected Contributor

Re: oracle patches

here is the requirements


PL/SQL native compilation,
Pro*C/C++,
Oracle Call Interface,
Oracle C++ Call Interface,
Oracle XML Developer's Kit (XDK) HP-UX 11i (11.11):
HP C/ANSI C Compiler (B.11.11.08):

C-ANSI-C
HP aC++ Compiler (C.03.50):

ACXX
HP-UX 11i v2 (11.23):

HP C/ANSI C Compiler (C.05.50):

C-ANSI-C
HP aC++ Compiler (C.05.50):

ACXX



and also see this doc , very useful

http://download.oracle.com/docs/html/B10766_08/prehpux.htm#CHDBIJCB
All things excellent are as difficult as they are rare
Jupinder Bedi
Respected Contributor

Re: oracle patches

Forums user name: sh5490
Company name:
Country / Region: india
Personal quote:
Certification:
ITRC member since: March 25, 2008
Last contribution date: February 17, 2010
I have assigned points to 0 of 89 responses to my questions.


and also this is what you porfile speaks . you have not assign even a single point to anyone till date. Please assign the points to those who respond to your question. this will encourage each and everyone in the forum
All things excellent are as difficult as they are rare
Dennis Handly
Acclaimed Contributor

Re: oracle patches

>we need to install OS patches for 11.23 ... which is not installed on server.

(These aren't OS patches.)
If you don't have this obsolete aC++ compiler already installed, then you should ignore this inaccurate Oracle requirement.

Steven E. Protter
Exalted Contributor

Re: oracle patches

Shalom,

These patches are needed for Oracle RAC. I confirm this.

Oracle requires compilers to install, because it builds binary files during the install process.

For some Oracle products I know alternate compilers have been used. See: http://hpux.connect.org.uk/hppd/hpux/Gnu/gcc-4.2.3/

Most installations, purchase the compilers listed above from HP and then install the oracle required patches.

In this case that is probably your only option, though you can try gcc. There are a lot of dependencies, and you must read carefully before proceeding.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Dennis Handly
Acclaimed Contributor

Re: oracle patches

>SEP: Oracle requires compilers to install, because it builds binary files during the install process.

My experience in the forum has been that the bundled C compiler is good enough to install Oracle database. For the Apps, you need aCC_link or the aC++ compiler.

>Most installations, purchase the compilers listed above from HP and then install the oracle required patches.

You can't purchase these particular obsolete versions.
Duncan Edmonstone
Honored Contributor

Re: oracle patches

SEP,

I reckon me and Dennis respond to at least 4 or 5 posts a month on this issue. The correct response in each case is that unless you actually want to compile some C or C++ code in your Oracle environment (thru Oracle ProC or ProC++), you _do not_ need the compiler products and associated patches.

The Oracle documentation and compiler is misleading in this respect, but I can confirm that I have installed and used Oracle and Oracle RAC on HP-UX many times without these products.

HTH

Duncan

HTH

Duncan
WayneHP
Frequent Advisor

Re: oracle patches

As per Jupinder Bedi's responds. If you do not select thoses products during your install you do not need the HP Compilers.

The standard linker that comes with HP-UX will handle your needs for the install.