Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

"The attempt to create the job failed" ERROR when trying to run swinstall

SOLVED
Go to solution
Steven Taylor_1
Occasional Visitor

"The attempt to create the job failed" ERROR when trying to run swinstall

When trying to run swinstall, swcopy or swremove, the following is received:

ERROR: The attempt to create the job failed. (Internal error)

ERROR: Command line parsing failed.

The system was working fine until I tried using swinstall after copying software into a depot using swcopy.

The swcopy worked successfully and there appear to be no errors in any of the sw logs associated with it.

I attempted to invoke swinstall by simply typing swinstall (as root).

I have tried stopping and starting the agent (swagentd) and even rebooting the box with no success.

Any help would be much appreciated.
4 REPLIES
A. Clay Stephenson
Acclaimed Contributor
Solution

Re: "The attempt to create the job failed" ERROR when trying to run swinstall

I'm guessing that the software job queue has become corrupt. Try this:

cd /sbin/init.d
./swagentd stop
mv /var/adm/sw/queue /var/adm/sw/queue.save
./swagentd start

The next invocation of swinstall should create a new queue. It would also be helpful to know if you received any other messages.


If it ain't broke, I can fix that.
Uday_S_Ankolekar
Honored Contributor

Re: "The attempt to create the job failed" ERROR when trying to run swinstall

Try moving files from var/adm/sw/queue to a safe place and restart the swagent by /usr/sbin/swagentd -r

-USA..
Good Luck..
Mark Greene_1
Honored Contributor

Re: "The attempt to create the job failed" ERROR when trying to run swinstall

Check the following log files in /var/adm/sw

swagent.log swconfig.log swinstall.log swpackage.log swagentd.log swcopy.log swmodify.log swverify.log

You should find some more detailed information about what line is failing.

mark
the future will be a lot like now, only later
Steven Taylor_1
Occasional Visitor

Re: "The attempt to create the job failed" ERROR when trying to run swinstall

That's done the job.

I've spent all afternoon trying to figure it out so I'm very grateful.