cancel
Showing results for 
Search instead for 
Did you mean: 

resolv.conf

SOLVED
Go to solution
John Carver
Frequent Advisor

resolv.conf

I have installed version 11.11 on a K360 in 64 bit. I set the network settings at first boot.
I have configured resolv.conf, nsswitch.conf and /etc/hosts the same as other machines I have running. I can't get get this new install to resolve to our dns machine. For example: when I try to ping a host on a different network, the command just hangs. My other HPUX hosts resolve just fine with these same configurations. I may be overlooking something very basic.
12 REPLIES
harry d brown jr
Honored Contributor
Solution

Re: resolv.conf

Default gateway???

Can you post:

netstat -rnv

cat /etc/resolv.conf
cat /etc/nsswitch.conf
cat /etc/rc.config.d/netconf

lanscan


As attachment would be great!

live free or die
harry
Live Free or Die
Wodisch
Honored Contributor

Re: resolv.conf

Hi John,

can you ping your own system with
#1: ping 127.0.0.1
# then TCP/IP is not bad
#2: ping DEFAULT-ROUTER # enter your default-router's IP-address here
# then your LAN-cards does work
#3: ping DNS-SERVER # enter DNS-server's IP-address here
# then your DNS-server is reachable

can you reach your DNS-server with
#4: nslookup $(hostname)
# then it answers
#5: nslookup www.your.company.com # or whatever a station in your domain is
#6: traceroute DNS-server # as in #3

Just tell us the output of these commands.

Regards,
Wodisch
Anil C. Sedha
Trusted Contributor

Re: resolv.conf

Hi John,

Just a few checks before you start changing things.

1) Have you registered your new system's IP address with your DNS subsystem. Many times, we forget registering our DNS entry.

2) If you have done this, verify that you are able to do the following and get results.

# ping localhost (you should get a good response)
# ping localrouter (give your router ip instead of localrouter).
# nslookup systemname (check your systemname is being resolved correctly by your DNS server and it is not giving any error while resolving your address or IP )

# verify that in /etc/nsswitch.conf you have this entry

hosts files [NOT FOUND=CONTINUE] dns

# in /etc/hosts
make sure you have the entries in order

172.*.*.* systemname test.us1.com
127.0.0.1 localhost loopback
172.*.*.1 primary NISserver
172.*.*.2 someotherservername

# try pinging now.

# if not then verify in
/etc/resolv.conf

domainname : listyourdomain
nameserver: serverip : name
nameserver2: serverip : name

You may stop your network services and restart them or reboot after doing all this.

Regards,
Anil (Don't forget to assign points if all this helps you)
If you need to learn, now is the best opportunity
John Carver
Frequent Advisor

Re: resolv.conf

These are the results of the commands that Wodisch recommended.
1. Yes, I can ping the local host, 127.0.0.1
2. Yes, I can ping my local router
3. No, I cannot ping my dns machine by ip
(the dns is up, I can ping it from another
machine)
4. nslookup on dns hostname fails
(works on another host)
5. nslookup on www.chapman.edu fails
(works from another host)
6. traceroute dns server fails
(works on another host)

Harry Brown requested the config files and the output of a couple of commands, they are attached.
steven Burgess_2
Honored Contributor

Re: resolv.conf

John

From your routing table entry it doesn't look as though the default gateway has been picked up

Your entry in your netconf file is commented out

Remove the comments

/sbin/init.d/net start

To re read the netconf file

HTH

Steve
take your time and think things through
steven Burgess_2
Honored Contributor

Re: resolv.conf

John

Sorry , this area

# ROUTE_DESTINATION[0]=default
# ROUTE_MASK[0]=""
# ROUTE_GATEWAY[0]="206.211.133.1"
# ROUTE_COUNT[0]="1"
# ROUTE_ARGS[0]=""


HTH

Steve
take your time and think things through
Anil C. Sedha
Trusted Contributor

Re: resolv.conf

I agree that the default entries for routes must be removed.

Don't forget to stop and start your network services after you have done this

/sbin/init.d/nfs.client stop
/sbin/init.d/nis.client stop
/sbin/init.d/nfs.server stop
/sbin/init.d/nfs.core stop

restart the same in the opposite order then.

i think you should be good to go. Right now your system is not able to find the gateway it should use. This should fix it

Regards,
Anil
If you need to learn, now is the best opportunity
Anil C. Sedha
Trusted Contributor

Re: resolv.conf

Sorry... i mistyped.

I meant "#" against default entries must be removed.

:-)
Regards,
Anil
If you need to learn, now is the best opportunity
John Carver
Frequent Advisor

Re: resolv.conf

How's that for not being able to see the obvious? I removed the commented lines in /etc/rc.config.d/netconf and restarted the daemon and everything works fine. Thanks to everyone who responded.
Anil C. Sedha
Trusted Contributor

Re: resolv.conf

John,

I think everyone would appreciate if you can assign points to whoever you think had valuable answers for you.

Regards,
Anil
If you need to learn, now is the best opportunity
harry d brown jr
Honored Contributor

Re: resolv.conf

I responded with "default gateway" because that is usually the answer 80% of the time and of course from "practice" if you know what I mean!

live free or die
harry
Live Free or Die
guodong_1
Occasional Visitor

Re: resolv.conf

Hi,john
I think maybe it is your route table's problem and not your dns's setting . just try to check the route table by using route -n . Maybe you can put more information of your server's setting ,then we can konw more detail .
guodong