cancel
Showing results for 
Search instead for 
Did you mean: 

setting stty defaults

Rich Wright
Trusted Contributor

setting stty defaults

Per the 'man stty' pages, I set an option by entering "stty stop
(The actual command was ...
stty stop $(echo "\023\c") ...because I could not find any other way
to get a ^S entered for the command.)


Then checked it with "stty -a The next day, I checked it again and "stop" was set back to .
I am having trouble finding any clues as to what could be changing the default setting back to .

I would like to know how the /dev/ttyconf file is used. There is no "man ttyconf". The only reference I could find is in "man stty".

"ll /dev/ttyconf" shows
crw------- 1 root sys 0 0x000001 Nov 11 1999 /dev/ttyconf
"lssf /dev/ttyconf" shows

pseudo driver cn minor 0x000001 /dev/ttyconf

The reason for all of this is a Fax sending package that was not working properly. I suspect that X-ON/X-OFF flow control was not working. Making the change fixed the problem, but I would like to make it permanent.



5 REPLIES
Rich Wright
Trusted Contributor

Re: setting stty defaults

I was reviewing my questions and saw that there was never an answer to this one.
Here is the solution.

1st, to set x-off you can use "stty stop '^S' < /etc/ttyconf" Where "^" and "S" are two separate characters. stty will see them and convert them to a single control character.

2nd, suggestion was to add a line to the /etc/inittab file like this...
stt1::sysinit:/sbin/stty erase '^S' (which did not work for my situation)

3rd, actual cause was a daily make_tape_recovery run to create an Ignite tape. This was changing it for a still unknown reason. So I added a line to our Ignite script to reset it.
EG:/sbin/stty stop '^S' intr '^?' quit '^\'
Sanjay_6
Honored Contributor

Re: setting stty defaults

Hi Rich,

To set ^S manully, try

shift+6 for "^" and then "S".

Hope this helps.

Regds
MANOJ SRIVASTAVA
Honored Contributor

Re: setting stty defaults

Rich


This is intresting , create a file and may be use cntrl v and cntrl s together , or you may like to change to a new shell.


Manoj Srivastava
Brian Crabtree
Honored Contributor

Re: setting stty defaults

The simplest thing that you can do is setup a .profile in your home with the stty commands that you want to have set automaticlly. Otherwise, editing the /etc/profile will make changes for all the users on the system.

This is the only way that I know of to make this change permanant.

Brian
Rich Wright
Trusted Contributor

Re: setting stty defaults

Slow down!

I don't think that anyone read my 2nd followup message.

I already solved this one myself.

If you really want points, answer why Ignite would be changing this setting and how to fix it. That is the 10 point question.