Simpler Navigation coming for Servers and Operating Systems
Coming soon: a much simpler Servers and Operating Systems section of the Community. We will combine many of the older boards, and you won't have to click through so many levels to get at the information you need. If you are looking for an older board and do not find it, check the consolidated boards, as the posts are still there.
cancel
Showing results for 
Search instead for 
Did you mean: 

shared resource permissions

Paul Wasik
Frequent Advisor

shared resource permissions

One out of many servers has oracle database semephores and shared mem with no group permissions. i.e. ipcs -a shows --rw-------. this is causing a problem with a monitoring tool. the DBA's are under the impression these perms are controlled like environmentals (i.e. umask). they have approaced server admin to get this corrected.

is it possible to control (from an OS user's account) shared resources permissions? how is that done?

in the oracle database is there "settings" in the config, or user settings, thta would control this?

thanks
3 REPLIES
Dennis Handly
Acclaimed Contributor

Re: shared resource permissions

I see nothing on shmget(2) that says it looks at umask. So it seems if there are no group permissions it's on purpose.
(I don't know about shm_open(2)?)

>is it possible to control shared resources permissions?

You can use shmctl(2) to change the permissions.
Paul Wasik
Frequent Advisor

Re: shared resource permissions

I found that the umask of the inetd to be 077 which impacted remote shells. this lead me to change root's current umask to 022. the inetd was stoped and restarted (inetd -k, inetd -l) after that the remote shells were started with a umask of 022.

later in the evening the database was resatrted, with a remote shell (or similar, it was actually an autosys job). the database shared resources were then readable by the group:

root@edwdelp2: ipcs | grep oracle
m 76440 0x669ca4f8 --rw-rw---- oracle dba
s 3858455 0x974e4330 --ra-ra---- oracle dba

it is suspected that the server's TCB setting was the cause of the default 077 umaks. the permanent (survives through reboot) solution is to alter the inetd start script to force a 022 umask in that script.

Paul Wasik
Frequent Advisor

Re: shared resource permissions

close