cancel
Showing results for 
Search instead for 
Did you mean: 

shmmax>1GB

SOLVED
Go to solution

shmmax>1GB

Hi All:
I need to increase shmmax > 1Gb but I receive the message that 1Gb is the maximun allowed value.
How I eliminate this limit ?
I'm working with rp7410 and HP-UX 11i
Best Regards,
2 REPLIES
S.K. Chan
Honored Contributor
Solution

Re: shmmax>1GB

I assume you know that if it's 32bit than the limit is 1GB, if 64bit and you're getting this error, there is a workaround to this. See this doc, you either install a patch or fix SAM config file.
DOCID=KBRC00008072
http://www1.itrc.hp.com/service/cki/docDisplay.do?docLocale=en_US&docId=200000062908957
Pete Randall
Outstanding Contributor

Re: shmmax>1GB

From SAM's "help on configurable paramters":

shmmax defines the system-wide maximum allowable shared memory
segment size in bytes. Any shmget() system call that requests a
segment larger than this limit returns an error (see shmget(2)).

Setting this value to 0x7fffffff has the effect of disabling this limit,
allowing the operating system to impose its own hard limit for shared
memory.

HTH,
Pete

Pete