Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

/usr/lib/pa20_64/dld.sl: Unable to find library 'libclntsh.sl.9.0'.

SOLVED
Go to solution
José J. Vellón
Occasional Contributor

/usr/lib/pa20_64/dld.sl: Unable to find library 'libclntsh.sl.9.0'.

#sfrpini
/usr/lib/pa20_64/dld.sl: Unable to find library 'libclntsh.sl.9.0'.
/usr/lib/pa20_64/dld.sl: Unable to find library 'libclntsh.sl.9.0'.

**********************

when I run a aplication show de following error
usr/lib/pa20_64/dld.sl: Unable to find library 'libclntsh.sl.9.0'.

My DB is Oracle 10.2.0.1.

my enviroment is correct but I dont know what happen

$ echo $LD_LIBRARY_PATH
/opt/lib/cobol/lib:/lvolora17/app/product/10.2.0.1/lib:/usr/lib:/lib

$ echo $SHLIB_PATH
/lvolora17/app/product/10.2.0.1/lib32:/lvolora17/app/product/10.2.0.1/rdbms/lib32:/lib


16 REPLIES
V. Nyga
Honored Contributor

Re: /usr/lib/pa20_64/dld.sl: Unable to find library 'libclntsh.sl.9.0'.

Hi,

use 'ldd ' and 'chatr ' to see where the library is expected.
Also search with find, where this library is.

Then you can add the path to LD_LIBRARY_PATH or create a link where it's expected.

HTH
Volkmar
*** Say 'Thanks' with Kudos ***
Srimalik
Valued Contributor

Re: /usr/lib/pa20_64/dld.sl: Unable to find library 'libclntsh.sl.9.0'.

You are using an application which was compiled with oracle 9i on a machine which do not have 9i dynamic libs.

solution

1) get a new version of application which is compiled with 10g

2) Install 9i and add <9ihome>/lib to LD_LIBRARY_PATH

3) In /lvolora17/app/product/10.2.0.1/lib create a link by the name libclntsh.9.0 which points to libclntsh.10.0 in the same directory.
this will make the application to use 10g lib. I have tried this and it will work unless oracle has changed the APIs, but I am not sure whether oracle will support this or not.
abandon all hope, ye who enter here..
Fat Scrape
Honored Contributor

Re: /usr/lib/pa20_64/dld.sl: Unable to find library 'libclntsh.sl.9.0'.

Hi,

I think that you must install oracle patch:

I had same problem and patch 10.2.0.2 solved my problem. But I don't remember the number of bug

Regards,
Fat Scrape
Honored Contributor

Re: /usr/lib/pa20_64/dld.sl: Unable to find library 'libclntsh.sl.9.0'.

Hi,

the script changePerm.sh is present on patchset 10.2.0.2

#!/bin/sh
#
# $Header: changePerm.sh 17-feb-2006.16:11:00 ssampath Exp $
#
# Copyright (c) 2005, 2006, Oracle. All rights reserved.
#
# NAME
# changePerm.sh - Change permission of files inside Oracle Home
#
# DESCRIPTION
# Reference bug : 4516865.
# Bugs fixed : 4516865, 4747264, 4908101 and 5039292
#
# History : In Oracle Database 10g Release 2, the Oracle Home was locked
# locked down by setting umask to 007 prior to installation.
# This had the affect of removing read,write,execute
# permissions for others on most files and directories.
#
# This script will relax the permissions on most files and
# directories in the installed Oracle Home, and allow "others"
# to access files within the database Oracle Home.
# Some of the directories and files (like log, trace, etc.,)
# will still have restricted access.
......

The permissions in $ORACLE_HOME/lib are now:

drwxr-xr-x 4 oracle oinstall 5120 Jun 13 15:45 /oracle/product/10.2.0/lib

Regards,

Srimalik
Valued Contributor

Re: /usr/lib/pa20_64/dld.sl: Unable to find library 'libclntsh.sl.9.0'.

Will this patch solve the problem? I think that there is no libclntsh.sl.9.0 shipped with 10g, they ship libclntsh.sl.10.0

sri
abandon all hope, ye who enter here..
Fat Scrape
Honored Contributor

Re: /usr/lib/pa20_64/dld.sl: Unable to find library 'libclntsh.sl.9.0'.

Hi Jose,

Have you, in your machine where you exec a query, oracle 10g or oracle 9?

Regards,
Fat Scrape
Honored Contributor

Re: /usr/lib/pa20_64/dld.sl: Unable to find library 'libclntsh.sl.9.0'.

...

and which is the application that you run?

José J. Vellón
Occasional Contributor

Re: /usr/lib/pa20_64/dld.sl: Unable to find library 'libclntsh.sl.9.0'.

The problem was that the program called to another program. The other program was not compiled with new /lib of 10g. I compile and solved the problem.

Thanks to All!
Srimalik
Valued Contributor

Re: /usr/lib/pa20_64/dld.sl: Unable to find library 'libclntsh.sl.9.0'.


Hi, Jose

what about assigning points to everybody who tried to help you :D ?

thanks
sri
abandon all hope, ye who enter here..
Fat Scrape
Honored Contributor

Re: /usr/lib/pa20_64/dld.sl: Unable to find library 'libclntsh.sl.9.0'.

Hi All,

The important think in this forum is to help others no to ask point.

Regards,

Fat Scrape
Srimalik
Valued Contributor

Re: /usr/lib/pa20_64/dld.sl: Unable to find library 'libclntsh.sl.9.0'.

Important thing it to provide help---Agreed
but points are not unimportant, that the reason they are there and every months a report is created.

points are less important than the help though.
abandon all hope, ye who enter here..
José J. Vellón
Occasional Contributor

Re: /usr/lib/pa20_64/dld.sl: Unable to find library 'libclntsh.sl.9.0'.

I do not understand the point. I only mean thanks to all to help me.
Fat Scrape
Honored Contributor
Solution

Re: /usr/lib/pa20_64/dld.sl: Unable to find library 'libclntsh.sl.9.0'.

Hi Jose,

Don't worry

Have you solved your problem? Yes, great!

Regards,

Fat
Dennis Handly
Acclaimed Contributor

Re: /usr/lib/pa20_64/dld.sl: Unable to find library 'libclntsh.sl.9.0'.

Fat Scrape
Honored Contributor

Re: /usr/lib/pa20_64/dld.sl: Unable to find library 'libclntsh.sl.9.0'.

Jose,

Please remove my point, I don't ask it.

Isn't necessary for me to have the points for a response, my satisfaction is to solve the problems.

Please remove the point assigned to me.

Regards,

Fat
José J. Vellón
Occasional Contributor

Re: /usr/lib/pa20_64/dld.sl: Unable to find library 'libclntsh.sl.9.0'.

thanks to all