Storage Boards Cleanup
To make it easier to find information about HPE Storage products and solutions, we are doing spring cleaning. This includes consolidation of some older boards, and a simpler structure that more accurately reflects how people use HPE Storage.
Disk Arrays
cancel
Showing results for 
Search instead for 
Did you mean: 

AutoPath eating processor time

SOLVED
Go to solution
Paul Slijkhuis
Valued Contributor

AutoPath eating processor time

Hi,

I have a process running called "apservice" that is taking a constant / permanent 50% processor time on both my processors of my dual processor L2000. This process is related to the AutoPath server which is installed as a service on a Microsoft windows 2000 cluster.

Does anyone knows if this is common behaviour?
Can I live without an Autopath server?
Is it a configuration issue?

I searched around, but so far I found this behaviour not documented...

Thanks, Paul
IT Architect, contractor
3 REPLIES
Marco Hogeveen
Honored Contributor
Solution

Re: AutoPath eating processor time

Hi Paul,

you probably have the latest version of Autopath software installed (1.04.00).
Autopath is used when you have 2 or more Fibre-channel Host Bus Adapters in your server. It provides load balancing/path failover functionality.

I've seen similar problems with this version. They are caused by the "Autopath Remote Access Server Service"

You can solve it by modify the installation (Control Panel, Add/remove software, HP Autopath 1.04.00) of autopath and deselect the autopath remote access server service (I believe it's number 5 from the top).
You need this only if remote access to this server is needed.

If you really need it, try an older version of autopath.

Good luck,

Marco
Paul Slijkhuis
Valued Contributor

Re: AutoPath eating processor time

You were correct about the version and the installation options.

Not just is now remote access disableed, also the autoPath GUI has become useless. It now only shows "local server is down". Still, AutoPath can be managed through the command line interface, so it seems still working correctly.

On the other hand I am surprised that this is not issued neither documented as a "know bug" of some kind. I strongly suggest HP takes this up in known behaviours in some cases at least.

So what i did is de-installed autopath remote server services, which uninstalls the process "apservice.exe" from the Windows 2000 Services. Now my processors are running on normal processor time again.

Regards, Paul
IT Architect, contractor
Marco Hogeveen
Honored Contributor

Re: AutoPath eating processor time

Hi Paul,

Now that the server service is disabled, you need to manually start the autopath server when you want to run the GUI.
Autopath automatically puts a shortcut on the desktop for this. You can also find it under Start -> Programs -> HP Autopath -> Start HP Autopath server.
If it's not there you can install it the same way you remove the Autopath remote access server service. Now you should select "HP Autopath Remote Access Server".

After you installed this, first start the autopath server and then the client.

Good luck,

Marco