Disk Arrays
cancel
Showing results for 
Search instead for 
Did you mean: 

Backup of BC LUNs on VA 7400

SOLVED
Go to solution
Lucian Deuter
Occasional Contributor

Backup of BC LUNs on VA 7400

Hi All,

I have problems with backup of Business Copy LUNs on a VA 7400 in my W2k environment. I have the following equipment:
2x lt6000r as DB Cluster1 with Oracle 9i and Failsafe on W2k Advanced Server. Each Server has 2 HBAs and Autopath VA.
2x lc2000rU3 as DB Cluster2 dito.
2x lc2000rU3 as W2k Domain Controllers each with 2 HBAs and Autopath VA
1x lh 3000rU3 as Backup Server with Veritas BackupExec NT/2000 8.6, also 2 HBAs and AP.
DB Cluster1 has access to 6 LUNs on the VA, Cluster2 has access to 12 LUNs, the domain controllers have each one LUN.
I created scripts, that switch the DBs in backup mode and then creates BC LUNs, that are backed up by the BU Server. After the backup I have to delete the BC LUNs because there is not enough disk space available on the VA to hold the snapshots. After deletion of the BC LUNs the BU Server pops up a "Unsafe Removal of Device" window and creates entries in the W2k System eventlog. Also it can happen that a "Write Delay failed" message occurs. I don't want these messages and the eventlog entries.

Is there any solution of such a problem or am I alone with it?
2 REPLIES
Vincent Fleming
Honored Contributor

Re: Backup of BC LUNs on VA 7400

I don't understand what you mean that the VA doesn't have enough space to hold the snapshots. They aren't really snapshots because you need enough space to completely copy the LUN in order to create the Business Copies - so, by definition, you have enough space.

Regardless of that, Windoze doesn't like it when devices just disappear. Waiting a little longer should help eliminate the "delay write failed" messages. Perhaps a 10-minute delay would do it.

I don't know how to make it stop complaining completely, but I suspect that if you could treat those LUNs as removable devices, it would fix your problem. Anybody out there know how to make SAN LUNs "look" like removable devices?

Good luck!
No matter where you go, there you are.
Erwin Zoer
Trusted Contributor
Solution

Re: Backup of BC LUNs on VA 7400

Hi Lucian,


With regards to the lost-delayed write data, I would consider trying to use the mountvol command before deleting the BC LUN. I'm not sure how the backup server currently accesses the BC, but if it is done by mounting the BC volume, this could be a solution. The reason the OS comes with this message is because data in the cache has not been flushed to disk yet. So, in addition you could consider to flush the disk cache manually using for example a tool from SysInternals (http:\\www.sysinternals.com). However, a proper dismount using the mountvol command, should do the same thing.

With regards to unsafe device removals, it is really the driver which decides whether or not it is acceptable for a device to disappear without prior warning. For the FC card driver/AutoPath unsafe removals of disks are not acceptable which is understandable. More detailed information regarding this can be found in 'HOWTO: Avoid Unsafe Removal Dialog Box (Q298504)'. Note that the solution in this article points out the use of the 'unplug or eject' hardware tool in the system tray. E.g. this can apparently not be scripted.

Last, I have found that you will not see the unsafe removal dialog boxes if you're not logged in. Hence, if the script runs without a logged in user, you should be fine.

I hope this helps.


Erwin