Disk Arrays
cancel
Showing results for 
Search instead for 
Did you mean: 

Connect netware to Enterprise Virtual Array

Eric van der Horst
Occasional Advisor

Connect netware to Enterprise Virtual Array

I connected a Netware server (5.1 and 6.0) via Fibre to an Entervprise Virtual Array (EVA). I created 5 virtual disks and presented them to one controller and one host (Netware connection needs to be Microsoft). I zoned the fabrics so that only one controller is visible to the Netware server. Only single path is supported at this moment.

When I make the LUNS visible on the Netware machine, I can only use 3 LUNS. The 4th and 5th are shown as 0KB. So I see them, but can do nothing with the LUNS.

Can someone tell me what the problem can be?

Firmware for FCA2210: 1.29
Driver for Netware: 6.50s
CPQSHD.CDM version: 1.54

As you see, I followed all the rules.

Thanks
2 REPLIES
Richard Litchfield
Respected Contributor

Re: Connect netware to Enterprise Virtual Array

When a NetWare server only has a single fibre channel card (HBA), no additional software (ie SecurePath) is required. Once the driver for the card is loaded, NetWare can use the storage presented by the SAN.

Naturally, if there is only one card (ie a single path), no redundancy is possible. If the HBA or cable fails, or the switch and controller the server is connected to fails, the storage will be unavailable. The storage will also be unavailable if the switch or controller is administratively disabled.

A NetWare server with single attach must only have a single path defined for it. If more than one path is defined, the server may get confused, and try to use the incorrect (unavailable) path. Ensure the preferred path/mode is fixed and set to failback.

A list devices from the command prompt should show the Admin connection on LUN0 and any other presented LUNs. On an EVA 3000 (HSV100) the assigned code is V597.

For the EVA the connection type should be set to unknown.

The problem described here sounds like a zoning issue - the server can still see both controllers through the single switch port it is connected to.
Bill Costigan
Honored Contributor

Re: Connect netware to Enterprise Virtual Array

I had the exact problem. And if you zone the switch so that the HBA sees the other controller on the EVA LUNs 4 and 5 will work but the other LUNs will show zero size.

In my case I could get all the even numbered LUNs or all the odd numbered but not both.

We only had a short time to test this and never found a solution. HP suggested we should have updated our EVA to the latest version (we had an older version of the software)

I also found a parameter for the qlogic driver that I wished I tried.
Load QL2300.HAM ..... /startunit

If you have an opportunity to test this please let me know if it fixes the problem.