Storage Boards Cleanup
To make it easier to find information about HPE Storage products and solutions, we are doing spring cleaning. This includes consolidation of some older boards, and a simpler structure that more accurately reflects how people use HPE Storage.
Disk Arrays
cancel
Showing results for 
Search instead for 
Did you mean: 

Device numbering problem

Dermot1
Advisor

Device numbering problem

Hi,

 

I have had this problem for a long time but never got round to doing anythinig about it.

 

I have an MSA 1500 with 4 x MSA  20's attached. The volume are SSP'd to a couple of servers running RedHat 5.2. At some point in the past the servers began to complain at boot up about read failures. I have assumed that this was because when I created a new volume on the disk array, the letter assignments would change. From the server I am able to see the new volume and use LVM to create new volumes so functionally they are fine. However I get screen-fulls of errors at boot time and when I use LMV tools. This is from pvscan:

 

  /dev/sda: read failed after 0 of 4096 at 0: Input/output error
  /dev/sda: read failed after 0 of 4096 at 2000341368832: Input/output error
  /dev/sda: read failed after 0 of 4096 at 2000341483520: Input/output error
  /dev/sda: read failed after 0 of 4096 at 0: Input/output error
  /dev/sda: read failed after 0 of 4096 at 4096: Input/output error
  /dev/sda: read failed after 0 of 4096 at 0: Input/output error
  /dev/sdb: read failed after 0 of 4096 at 0: Input/output error
  /dev/sdb: read failed after 0 of 4096 at 2000341368832: Input/output error
  /dev/sdb: read failed after 0 of 4096 at 2000341483520: Input/output error
  /dev/sdb: read failed after 0 of 4096 at 0: Input/output error
  /dev/sdb: read failed after 0 of 4096 at 4096: Input/output error
  /dev/sdb: read failed after 0 of 4096 at 0: Input/output error
  /dev/sdc: read failed after 0 of 4096 at 0: Input/output error
  /dev/sdc: read failed after 0 of 4096 at 1500244410368: Input/output error
  /dev/sdc: read failed after 0 of 4096 at 1500244492288: Input/output error
  /dev/sdc: read failed after 0 of 4096 at 0: Input/output error
  /dev/sdc: read failed after 0 of 4096 at 4096: Input/output error
  /dev/sdc: read failed after 0 of 4096 at 0: Input/output error
  /dev/sdd: read failed after 0 of 4096 at 0: Input/output error
  /dev/sdd: read failed after 0 of 4096 at 1500244410368: Input/output error
  /dev/sdd: read failed after 0 of 4096 at 1500244492288: Input/output error
  /dev/sdd: read failed after 0 of 4096 at 0: Input/output error
  /dev/sdd: read failed after 0 of 4096 at 4096: Input/output error
  /dev/sdd: read failed after 0 of 4096 at 0: Input/output error
  /dev/sde: read failed after 0 of 4096 at 0: Input/output error
  /dev/sde: read failed after 0 of 4096 at 1500244410368: Input/output error
  /dev/sde: read failed after 0 of 4096 at 1500244492288: Input/output error
  /dev/sde: read failed after 0 of 4096 at 0: Input/output error
  /dev/sde: read failed after 0 of 4096 at 4096: Input/output error
  /dev/sde: read failed after 0 of 4096 at 0: Input/output error
  /dev/sdf: read failed after 0 of 4096 at 0: Input/output error
  /dev/sdf: read failed after 0 of 4096 at 1500244410368: Input/output error
  /dev/sdf: read failed after 0 of 4096 at 1500244492288: Input/output error
  /dev/sdf: read failed after 0 of 4096 at 0: Input/output error
  /dev/sdf: read failed after 0 of 4096 at 4096: Input/output error
  /dev/sdf: read failed after 0 of 4096 at 0: Input/output error
  /dev/sdg: read failed after 0 of 4096 at 0: Input/output error
  /dev/sdg: read failed after 0 of 4096 at 1500244410368: Input/output error
  /dev/sdg: read failed after 0 of 4096 at 1500244492288: Input/output error
  /dev/sdg: read failed after 0 of 4096 at 0: Input/output error
  /dev/sdg: read failed after 0 of 4096 at 4096: Input/output error
  /dev/sdg: read failed after 0 of 4096 at 0: Input/output error
  /dev/sdh: read failed after 0 of 4096 at 0: Input/output error
  /dev/sdh: read failed after 0 of 4096 at 1500244410368: Input/output error
  /dev/sdh: read failed after 0 of 4096 at 1500244492288: Input/output error
  /dev/sdh: read failed after 0 of 4096 at 0: Input/output error
  /dev/sdh: read failed after 0 of 4096 at 4096: Input/output error
  /dev/sdh: read failed after 0 of 4096 at 0: Input/output error
  /dev/sdi: read failed after 0 of 4096 at 0: Input/output error
  /dev/sdi: read failed after 0 of 4096 at 2000341368832: Input/output error
  /dev/sdi: read failed after 0 of 4096 at 2000341483520: Input/output error
  /dev/sdi: read failed after 0 of 4096 at 0: Input/output error
  /dev/sdi: read failed after 0 of 4096 at 4096: Input/output error
  /dev/sdi: read failed after 0 of 4096 at 0: Input/output error
  /dev/sdj: read failed after 0 of 4096 at 0: Input/output error
  /dev/sdj: read failed after 0 of 4096 at 2000341368832: Input/output error
  /dev/sdj: read failed after 0 of 4096 at 2000341483520: Input/output error
  /dev/sdj: read failed after 0 of 4096 at 0: Input/output error
  /dev/sdj: read failed after 0 of 4096 at 4096: Input/output error
  /dev/sdj: read failed after 0 of 4096 at 0: Input/output error
  PV /dev/sdk1           VG vg_k001   lvm2 [1.72 TB / 0    free]
  PV /dev/sdl1           VG vg_k001   lvm2 [1.72 TB / 0    free]
  PV /dev/sdm1           VG vg_k001   lvm2 [1.30 TB / 0    free]
  PV /dev/sdn1           VG vg_k001   lvm2 [1.30 TB / 5.86 GB free]
  PV /dev/cciss/c0d2p1   VG vg2       lvm2 [136.70 GB / 712.00 MB free]
  PV /dev/sds1           VG vg_k003   lvm2 [1.82 TB / 0    free]
  PV /dev/sdt1           VG vg_k003   lvm2 [1.82 TB / 8.80 GB free]
  PV /dev/cciss/c0d1p1   VG vg        lvm2 [68.33 GB / 3.33 GB free]
  PV /dev/sdr1           VG vg_subs   lvm2 [1.36 TB / 0    free]
  PV /dev/sdo1           VG vg_k002   lvm2 [1.30 TB / 0    free]
  PV /dev/sdp1           VG vg_k002   lvm2 [1.30 TB / 0    free]
  PV /dev/sdq1           VG vg_k002   lvm2 [1.30 TB / 0    free]

 

The devices that begin /dev/s?? are from the fibre attached MSA 1500.  It complains about 10 devices and that is the total number of devices that are assigned to the server's FC adapter. Likewise on the other server it complains about 4 devices and that is the number of volumes assigned to that server's FC adapter.

 

Does anyone know how I can remove these errors? Is this something that udev can help with or some trick with LVM perhaps?

Thanks,

Dermot