Storage Boards Cleanup
To make it easier to find information about HPE Storage products and solutions, we are doing spring cleaning. This includes consolidation of some older boards, and a simpler structure that more accurately reflects how people use HPE Storage.
Disk Arrays
cancel
Showing results for 
Search instead for 
Did you mean: 

EVA4000: vdisk could not be shown on windows platform

SOLVED
Go to solution
stephen peng
Valued Contributor

EVA4000: vdisk could not be shown on windows platform

dear all,
i installed some DL580s to use vdisk on EVA4000. first time i used FAT filesystem type to install windows 2003 server on one DL580, and it was ok, and in system devices manager, the HSV200 device were also ok. but when i installed them using NTFS filesystem type(for filesystem type purpose), i could no longer see the vdisk on DL580. i have some questions:
1, how can i figure out the WWN of the HBA on DL580? i want to know whether i configure the host on SMA in some correct way.
2, it that wrong to install windows 2003 server using NTFS filesystem type on DL580?
3, do i need to install some driver on windows 2003 server to query the vdisk on EVA4000? what should i do to complete the whole installation?
thanks for your reply.
9 REPLIES
VCP2005
Trusted Contributor

Re: EVA4000: vdisk could not be shown on windows platform

pls repeat your problem, as file system type (FAT32 & NTFS) should not affect the EVA vdisk. May be you need verify the disk from MPIO/Disk Management from Window management window

1. WWN can be found from SAN switch, Emulex card can also get from lputil. Qlogic should able to get from SANsurf

2. Nope, it should be NTFS

3. you need to install supported HBA driver, and multipath software should be install MPIO (free from Microsoft)

http://www.microsoft.com/windowsserver2003/technologies/storage/mpio/default.mspx

stephen peng
Valued Contributor

Re: EVA4000: vdisk could not be shown on windows platform

hi Liewwk ,
firstly i used FAT for boot partition to install the DL580, and after i present a vdisk on SMA to this DL580, and the vdisk was shown on DL580, and in device manager of windows management window, the HSV200 device was shown in ok status. after that, i used NTFS for boot partition to install the DL580,wrong status appeared, the HSV200 device was shown in wrong status, although i could see the vdisk in Disk Management from Window management window. furthermore, i've got the LAN cards disable and could not enable, saying them conflicted with other devices. and in other DL580 using NTFS to install, the vdisks could not be seen on it though i had present those vdisks to those hosts.
i have installed the HBA driver, and the HBA status in device management window was ok, just the HSV200 devices(meaning vdisk)' status was not ok.
is that Iputil a windows tool?
is MPIO a multipath software like HP's securepath and act the same function?
anyway, thank you for your opinion
VCP2005
Trusted Contributor

Re: EVA4000: vdisk could not be shown on windows platform

Hi Stephen,
The vdisk detection should not affect by your OS filesystem type. Please verify the presentation of the vdisk to correct WWN. Do you restart the server while first vdisk assign to the "problem" server ? Please restart it.

LPUTIL is a tool by Emulex which come with driver installation.

MPIO is like secure path from HP, but as secure patch is license software plus it is no more development or enhancement but MPIO is free and is future use software for all the SAN storage on Windows.
stephen peng
Valued Contributor

Re: EVA4000: vdisk could not be shown on windows platform

hi Liewwk,
could you please offer my the download link of the MPIO? i could not find it out.
the vdisk can be shown on DL580s now, and they appeared in the disk management windows as two paths without installing MPIO, one in the status of dynamic and online, and other in the status of dynamic and offline. what should i configure this two disks to make them suitable for windows usage?
thank you.
VCP2005
Trusted Contributor
Solution

Re: EVA4000: vdisk could not be shown on windows platform

Details for how to install MPIO
http://download.microsoft.com/download/e/b/a/eba1050f-a31d-436b-9281-92cdfeae4b45/multipathmpio.doc#_Toc87853334

the disk should be 1 online & the other offline if you do not have Multipath software

You can get MPIO from HP website driver & software > search for MPIO EVA

or

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareIndex.jsp?lang=en&cc=us&prodNameId=421494&prodTypeId=12169&prodSeriesId=421492&swLang=8&taskId=135&swEnvOID=1005
stephen peng
Valued Contributor

Re: EVA4000: vdisk could not be shown on windows platform

liewwk,
thank you very much, you are so helpful!
stephen peng
Valued Contributor

Re: EVA4000: vdisk could not be shown on windows platform

hi liewwk,
another question, is there some tools use as compaq's NetRAIN on Windows? software or driver
thanks
VCP2005
Trusted Contributor

Re: EVA4000: vdisk could not be shown on windows platform

Hi Stephen,
Do you wish to use NetRain for NIC failover or loadbalance ?

HP Proliant provie "HP Network" can easily do the network teaming for either load balance or failover purpose. If you install ur Proliant with SMART start CD, then the icon should start while u boot ur windows on ur task bar on ur right bottom.
stephen peng
Valued Contributor

Re: EVA4000: vdisk could not be shown on windows platform

hi liewwk,
thank you, and once again, you are just so helpful, could you please read my other thread?
http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=1028814