Disk Arrays
cancel
Showing results for 
Search instead for 
Did you mean: 

EVA6400 high hostport queue depth

EVA6400 high hostport queue depth

Hi,

 

I have a 2C12D EVA6400 - its reasonably utilised, however after some analysis I noticed that a connected host is reporting a high queue depth on only one controller host port .

when I say 'high' it has been sitting on ~65000 for a long time now.

I am just wanting to try and get some help on how to trace it back to an individual vdisk - or identify if there is a problem with the HBA on the connected host.

I do not see any high latency or high use on any of the vdisks connected to this host.


Name  Read   Read    Read Write     Write     Write     Av. Port                Ctlr
             Req/s   MB/s Latency Req/s   MB/s Latency Queue WWN
                     (ms)                 (ms)                                     Depth
---- ----- ------ ------- ----- ------ ------- ----- ------------------- ----

FP2       57      0.80          7.7      118     1.10      0.5       65542                   5001-4380-025B-A029 L013

 

 

Any ideas on how to trace this back through the stack to clearly ID the problem?

There are no errors on any of the SAN switch ports connected to the EVA or the host.

 

Thanks

5 REPLIES
Johan Guldmyr
Honored Contributor

Re: EVA6400 high hostport queue depth

Hello, you could gather some evaperf output and then ask HP support for some assistance in making it more 'visual' in case you don't want to plot/parse the .csv file yourself.

In there you could even get statistics down to a single physical disk.

Is this host only accessing the EVA through FP2 on one controller?

This may be of some assistance regarding evaperf:

http://h20566.www2.hp.com/portal/site/hpsc/template.PAGE/public/kb/docDisplay/?javax.portlet.tpst=ba847bafb2a2d782fcbb0710b053ce01&javax.portlet.prp_ba847bafb2a2d782fcbb0710b053ce01=wsrp-navigationalState%3DdocId%25253Demr_na-c01809990%25257CdocLocale%25253Den&javax.portlet.begCacheTok=com.vignette.cachetoken&javax.portlet.endCacheTok=com.vignette.cachetoken

Re: EVA6400 high hostport queue depth

Hi, we had gathered data for a week and sent it to HP which is where I saw the high queue depth in the graph.
I am not sure if the host is only accessing it through this port - it is zoned to all ports, and it seems to be able to access via the other controller.
but the high queue depth is still present on this port.

thanks
Johan Guldmyr
Honored Contributor

Re: EVA6400 high hostport queue depth

You should be able to determine which path the host uses by looking at the config for that host in your multipath settings.

Re: EVA6400 high hostport queue depth

sadly its an HP-UX server and I am contracting to this client and cannot seem to contact anyone who wants to assist me with it... :)

 

I will keep looking - I am guessing its the HBA on the HP-UX host, its an integrity c-class blade server - the HBA type/driver wont even show up on the switches!

Jeremy C
Regular Advisor

Re: EVA6400 high hostport queue depth

Any resolution to this?

 

I'm experiencing the same thing intermittently.  I believe it to be a bug in evaperf causing bogus numbers.  I get average queue depth values around 65,000 one one port with no evidence of high IO or latency.

 

Currently using CommandView EVA 10.3.