Disk Arrays
cancel
Showing results for 
Search instead for 
Did you mean: 

FC-60 LUN stuck on rebuilding

Greg Wierzchowski
Occasional Visitor

FC-60 LUN stuck on rebuilding

We have a FC-60 disk array and one of the LUNs with two disks configured as mirror shows status as degraded - rebuilding, but both disks show as optimal, and the rebuild progress stays at zero percent (several days now). The OS can access the data just fine (LUN mounted). I'm not sure how to proceed, short of rebuilding the LUN, which I'd like to avoid.
Any ideas?
4 REPLIES
skris
Trusted Contributor

Re: FC-60 LUN stuck on rebuilding

Hi Could you attach a amdsp -a $id output of the Array? let's see if we can find something.

Cheers!
Shiva
Greg Wierzchowski
Occasional Visitor

Re: FC-60 LUN stuck on rebuilding

Sorry, I shoud have thought about that. Here it is, attached the output of amdsp -a.
skris
Trusted Contributor

Re: FC-60 LUN stuck on rebuilding

The Logs look ok except for this one drive(4:3);
Im not sure why the members are restarting a rebuild;

The drive that's not responding can be found here:
SCSI Channel:ID = 4:3;

Cheers!
Shiva
Greg Wierzchowski
Occasional Visitor

Re: FC-60 LUN stuck on rebuilding

Thanks for the input. The other disk is easy to fix, I can replace it, but what I was really looking for, was to find a way to fix this degraded status of the LUN. I said before that both individual drives look OK. Little background - Initially I thought there was a problem with the controller, and this LUN was showing up as not responding. I tried assigning this LUN to the other controller and it did not change the ownership but all of the sudden the LUN was good, except for the rebuilding status stuck at 0%. It's an old piece of hardware but I'm stuck with it. I guess this is one of the great mysteries of the universe...