Disk Arrays
cancel
Showing results for 
Search instead for 
Did you mean: 

FC10 configured jbod with mirrordisk errors

Steve Lewis
Honored Contributor

FC10 configured jbod with mirrordisk errors

We are having some problems with LVM Mirrordisk/UX and our FC10, 2 disks failed in 2 days in the same (odd) fashion, powerfailing and recovering in the same second over several hours. When it fails, it attempts to switch to the other controller and marks the LV as stale, yet I can lvsync the LV and recover it. This has happened to disks on both c8 and c9.
Our FC10 is connected through two controllers directly to our N4000. No FC60 on this server as it is too expensive for us.
All 10 disks are in vg01, 5 have c8 as primary, c9 as alternate path, the other 5 have c9 as primary, c8 as alternate path. The logical volumes are split, half on the c8 disks, mirrored to the c9, half on the c9 disks mirrored to the c8 ones.
e.g. vg01/lvapps is on c8t1d0 (alternate path c9t1d0) mirrored to c9t6d0 (alternate path c8t6d0).

Does anyone know if this is a supported configuration, or should we drop the alternate paths to each disk, in case it is confusing the system?

5 REPLIES
Bill McNAMARA_1
Honored Contributor

Re: FC10 configured jbod with mirrordisk errors

mmmmm, when was the last time you firmware upgraded the LCCs?

Although it's possibly an LVM problem.

I'd run tools-info-run
from mstm on the enclosure and disk..

Later,
Bill
It works for me (tm)
Krishna Prasad
Trusted Contributor

Re: FC10 configured jbod with mirrordisk errors

I agree check the latest firmware and you might also want to check your patch level for lvm,vxfs,scsi,hfs,the HPA card...etc
Positive Results requires Positive Thinking
Steve Lewis
Honored Contributor

Re: FC10 configured jbod with mirrordisk errors

Its a remarketed server with Dec 2001 patch bundle, except the firmware on the disks themselves varies HP01-HP09. Maybe I will check for later revisions to the loop controller firmware etc...
Matt Walls
Advisor

Re: FC10 configured jbod with mirrordisk errors

I have a similiar configuration, however, I have FC hubs in between.

I also had similiar problems that you described. The fix was firmware on the disks and possibly the N server or the FC10 itself.

Downtime will be required.

This is a known bug within HP.
Since the firmware updates, all has been flawless!

Matt

Re: FC10 configured jbod with mirrordisk errors

I resolved the same problems with Firmware upgrades, only difference is my configuration was more in-lined with Matt's - I had a Brocode switch between - Try firmware update and let us know!
The greatest risk one take is not taking one!