Disk Arrays
cancel
Showing results for 
Search instead for 
Did you mean: 

FC60 issue (plz help)

meekrob
Super Advisor

FC60 issue (plz help)

Hi All,

 

could you please help with the following issue with an FC60 array:

i received the following message from EMS:

 

>------------ Event Monitoring Service Event Notification ------------<

 

Notification Time: Tue Apr 10 01:17:49 2012

 

srv1 sent Event Monitor notification information:

 

/storage/events/disk_arrays/FC60/001600A0B8067E98
 is >= 3.
Its current value is SERIOUS(4).

 

 

 

Event data from monitor:

 

Event Time..........: Tue Apr 10 01:17:49 2012
Severity............: SERIOUS
Monitor.............: fc60mon
Event #.............: 6                  
System..............: srv1.org

 

Summary:
     Disk Array at hardware path  :
Array at hardware path , path 0/3/1/0.8.0.4.0.0.0:  The controller in slot A
has failed, or is not accessible
 

 


Description of Error:

 


   This event message is displayed by one of several conditions:
 
   1. Problem with the connection.
   2. Interface cable/terminator.
   3. Controller.
   4. Host but Adapter.
 

 

Probable Cause / Recommended Action:

 


   Replace the indicated controller.

 

Additional Event Data:
     System IP Address...: 192.168.250.2
     Event Id............: 0x4f837c2d00000000
     Monitor Version.....: B.01.02
     Event Class.........: I/O
     Client Configuration File...........:
     /var/stm/config/tools/monitor/default_fc60mon.clcfg
     Client Configuration File Version...: A.01.01
          Qualification criteria met.
               Number of events..: 1
     Associated OS error log entry id(s):
          None
     Additional System Data:
          System Model Number.............: 9000/800/rp3440  
          EMS Version.....................: A.04.20
          STM Version.....................: A.49.00
     Latest information on this event:
          http://docs.hp.com/hpux/content/hardware/ems/fc60mon.htm#6

 

However, as you can see attached, it seems normal from the output of:      amdsp -a <arrayid>   

 

How can i proceed with troubleshooting and what causes this error?

 

Many Thanks

13 REPLIES
meekrob
Super Advisor

Re: FC60 issue (plz help)

After more verification of the amdsp -a output attached, i noticed the following line corresponding to LUN 31 or UTM

 

31  OPTIMAL              20.0 MB   A     0         32  Can't identify

 

Any help will be much appreciated.

 

Thanks in advance

hvhari
HPE Pro

Re: FC60 issue (plz help)

you will get this error in hpux, when there is a disturbance is in the connectivity (like some one took away cable for some reason for a moment). As the amdsp is not revealing any error on controller, it is safe to ignore this.

 

The disk mentioned by you should be a failed disk which may require replacement. You may contact HP support for replacement.

Regards,
Hari

If this post was useful , click the Kudos Star on the left side to say Thanks!
meekrob
Super Advisor

Re: FC60 issue (plz help)

Thanks for your help much appreciated.
However, LUN31 is a special LUN for UTM usage and normally should not contain any disk and instead of the "Can't identify" state it should be stating "UTM:GOOD" only in normal behaviors.
hvhari
HPE Pro

Re: FC60 issue (plz help)

Yes, the disks that were part of lun31 has some issue.

 

Some of the disks are in "unassigned" state . (disks - 2:3, 4:3, 6:3)

 

If you have captured amlog HP support should be able to help. Or if you can upload amlog here, some one on the forum might be able to look further.

 

 

Regards,
Hari

If this post was useful , click the Kudos Star on the left side to say Thanks!
meekrob
Super Advisor

Re: FC60 issue (plz help)

Hello and once again for your suggestion. As i said LUN31 in fc60 configuration is a special LUN to which no disks are assigned it is just used for UTM. As for the unassigned disks thats true as there are 3 disks installed in the disk arrays and they are not used (do not belong to any LUN ) and this isnt seem to cause a problem. As for the logs do i just issue amlog command?

Once again thanks for your support
meekrob
Super Advisor

Re: FC60 issue (plz help)

kindly find attached the output of the "amlog" command.

 

Thanks in advance for your suggestions

hvhari
HPE Pro

Re: FC60 issue (plz help)

Hi,

Logs does report removal/reset of controller. As there is no issue with controller now there is no action requried.

 

I have not seen this issue with UTM lun before. If you contact HP support they may be able to check it. OR you may try disabling/enabling the UTM as per the advanced user guide page 322 at http://bizsupport2.austin.hp.com/bc/docs/support/SupportManual/c00744713/c00744713.pdf

 

This guide also mentions methods to collect detailed logs with a specified time frame.

Regards,
Hari

If this post was useful , click the Kudos Star on the left side to say Thanks!
meekrob
Super Advisor

Re: FC60 issue (plz help)

Hi again and thaks for your help.

In fact, after replacing the controller in slot A, it seems that it took care of the issue.

Really weird as no logs in the amdsp -a output showing controlA is bad.

Those FC60 are really weird :)

 

Thanks once again for your help.

Thread closed

meekrob
Super Advisor

Re: FC60 issue (plz help)

Hi All,

 

after replacing the controller A, everything went GOOD for a while but now we're back to the same situation as before with the controller A status : "UNKNOWN" (file in attachment) .

Those FC60 are so tricky so i dunno if im missing something here; any help / suggestion is precious to me.

 

Thanks in advance

hvhari
HPE Pro

Re: FC60 issue (plz help)

"UNKNOWN" controller does indicate a HW issue. It could be a dead controller or just a seating issue of the controller. Was this reported to HP Support?

Regards,
Hari

If this post was useful , click the Kudos Star on the left side to say Thanks!
meekrob
Super Advisor

Re: FC60 issue (plz help)

Hello Hari and thanks for your reply / opinion.

In fact we already logged the case but our environment can not tolerate a downtime.

We've been delivered a new controller so we proceeded by replacing the controller in question and all went fine for a short period (the "UNKNOWN controller" message disappeared for a while) but now we are having the old message once again. I really just need to know what's happening as management always ask such questions you know ;) especially after purchasing new controllers and replacing the old ones.

Could it be the controllers' backplane on which are inserted the 2 controllers and in that case more specifically the 1st upper slot belonging to controller A ?? or could it be a connection / cable issue?How to proceed with the troubleshooting?

In fact im imagining cases as im not too familiar with those FC60 tricks.

 

Any opinion / suggestion is welcomed.

 

Thanks in advance

hvhari
HPE Pro

Re: FC60 issue (plz help)

Issue with seating or the backplane can be isolated only with physical observation. You may check the LED status of the "good" controller and compare this with the controller having issue. There is a reset button available in each controller and you could try reseting the problematic controller. Also have a check on the cables connected to controller ports for host connectivity.

 

 

 

Regards,
Hari

If this post was useful , click the Kudos Star on the left side to say Thanks!
meekrob
Super Advisor

Re: FC60 issue (plz help)

OK noted. Many Thanks