cancel
Showing results for 
Search instead for 
Did you mean: 

Firmware

John Olcott
Occasional Contributor

Firmware

I'm trying to update firmware for disk (ST318203LC) in a 12H array but I keep getting this error:

hpuxk1-/ # download -d A1 /john/PF_DSEACH3HP04.frm 000000057AAB
Copyright (C) 1995, 1997 Hewlett-Packard Company
Revision HP01 of drive model ST318203LC
Shutting Down
Shutdown Complete
(Loading Mechanism Firmware)
Pass-thru `Write Buffer' command failed: SCSI error.
SCSI status: 2 `CHECK CONDITION'
SCSI sense: 5 `ILLEGAL REQUEST'
ASC/ASCQ: 26/99

sense data: 70 0 5 0 0 0 0 12
sense data: 0 0 0 0 80 c 0 0
sense data: 0 0 4 0 1f 0 5 26
sense data: 99 0

Initializing
Unexpected command state 1 encountered!

AutoRAID firmware download program ending.
hpuxk1-/ #
5 REPLIES
A. Clay Stephenson
Acclaimed Contributor

Re: Firmware

First make sure that you cksum your file and encure that it agees with the cksum value published with the firmware release notes. It is death to install a bad firmware file.

I would try using a SCSI path to LUN 0 on the array rather than the array serial number. In a few cases, I've had the pathname work where the array id would not. You should also make sure that the array manager software is up to date. It includes the download command and ther arraymgt software is closely tied to the array controller firmware.
If it ain't broke, I can fix that.
e4services
Honored Contributor

Re: Firmware

John, why would you attempt to load a differnet hard disk firmware? Seagate does not suggest this, "The Drive's firmware version is very important. Applying the wrong firmware to a drive could possibly damage the drive." This should be attempted ONLY if you are have some trouble with the drive's existing firmware.
http://www.seagate.com/support/kb/disc/faq/firmware_rev.html
Hot Swap Hard Drives
A. Clay Stephenson
Acclaimed Contributor

Re: Firmware

You don't mention your OS version but the latest cumulative AutoRAID patch has a fix for exactly your problem (upgrading firmware on disks). For 11.11, it's PHCO_23263 but check under the "Equivalent Patches" of the Release Notes for PHCO_23263 for other versions.
If it ain't broke, I can fix that.
John Olcott
Occasional Contributor

Re: Firmware

The patch says it's for st318203lc drives. That's what I'm trying to update.
John Olcott
Occasional Contributor

Re: Firmware

I already have the patch installed, cksum gives me the correct output, I have the latest version of the Armserver software, os version 11.11, used the /dev/rdsk path for the lun but I still get the same error.