Disk Arrays
cancel
Showing results for 
Search instead for 
Did you mean: 

MSA1000 CLI not allowing input of commands

SOLVED
Go to solution
Guy Beukes
Advisor

MSA1000 CLI not allowing input of commands

Were having a few problems with a MSA1000. Its been taken out of a previous configuration and we need to set it up for a new configuration. Unfortunately the CLI is only showing us information, not allowing us to input anything. Ive been reading alot of the forums and there has been talk that the MSA1000 might need to have the CLI installed before it becomes available for bi directional communication. Is this the case? and if so, How do I set it up as the ACU will only run on a windows 2003/2000 box and Im running XP?
16 REPLIES
Rob Leadbeater
Honored Contributor

Re: MSA1000 CLI not allowing input of commands

Hi,

I've seen this once when the PC talking to the MSA had a duff serial port.

Try connecting it to another machine and see if it works there...

Hope this helps,

Regards,

Rob
Guy Beukes
Advisor

Re: MSA1000 CLI not allowing input of commands

Thanks Rob, Tried a couple of laptops already, im connecting a windows 2003 server to see if that makes any difference.
Rob Leadbeater
Honored Contributor

Re: MSA1000 CLI not allowing input of commands

Probably won't help, but I take it you've got the correct serial port settings....

Baud: 19200
Data bits: 8
Parity : None
Stop bits: 1
Flow control: None

You might also want to check that the serial cable isn't damaged... Maybe the transmit pin isn't connected correctly...

Cheers,

Rob
John Kufrovich
Honored Contributor

Re: MSA1000 CLI not allowing input of commands

I would also check the terminal speed. It is common for individuals to change the speed to 57600.
Guy Beukes
Advisor

Re: MSA1000 CLI not allowing input of commands

I cannot comment on the cable, its new and direct from HP, confirmed the model number of the cable as well. Not too sure how I would check the cable, physically it looks fine.

I can also confirm that I am using the settings obtained out of the CLI user guide.

Had no luck loading the ACU and CLI software onto a windows 2003 machine. I dont think it can connect over com port.
Rob Leadbeater
Honored Contributor

Re: MSA1000 CLI not allowing input of commands

The ACU software talks to the MSA via fibre rather than serial...

Cheers,

Rob
Guy Beukes
Advisor

Re: MSA1000 CLI not allowing input of commands

Thanks for that.

Im attaching the log files showing the startup procedure for the MSA1000, hopefully you chaps can spot something.
John Kufrovich
Honored Contributor

Re: MSA1000 CLI not allowing input of commands

Wow, 1.16 FW
That FW version was cli output only.


jk

Guy Beukes
Advisor

Re: MSA1000 CLI not allowing input of commands

So then I guess we should be upgrading the firmware. Damn, anybody know how to do that without cli?
Uwe Zessin
Honored Contributor

Re: MSA1000 CLI not allowing input of commands

Firmware upgrades are done via a server.

But before you start, you need to find out if your MSA1000 has one of the early EMUs which had a non-flashable "Flash"-chip - no, I kid you not!
There was a replacement program when the MSA1000 was new - don't know what the current state is.
.
Rob Leadbeater
Honored Contributor
Solution

Re: MSA1000 CLI not allowing input of commands

Hi,

You can't update via the serial console on the early firmware. I just had to update an MSA1000 that was running firmware 2.xx.

The CLI on that version does work properly, however there isn't a "download firmware" command, that you get in the latter releases.

You'll have to connect the MSA up to a server via fibre, then run the MSA Flash utility, available from the download pages here:

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareIndex.jsp?lang=en&cc=us&prodNameId=305215&prodTypeId=12169&prodSeriesId=377751&swLang=8&taskId=135&swEnvOID=1005

Cheers,

Rob
Guy Beukes
Advisor

Re: MSA1000 CLI not allowing input of commands

Thanks for all the help chaps. Ive been scowering the interwideweb looking for information about the upgrades and I have noticed that were way behind in regards to the firmware.

You spoke about upgrading your firmwar from version 2.? to the latest one. Did you jump straight to version 7.? or did you have to step up?, if so were did you get the older versions of the firmware. I've managed to find version 6.31 on an old compaq ftp server.

What method did you use for the upgrade? the firmware cd or did you use the windows MSA flash utility?
Rob Leadbeater
Honored Contributor

Re: MSA1000 CLI not allowing input of commands

Hi,

I went straight from 2.x to 5.20 using the MSA Flash utility, without any problems.

As version 7.00 introduces Active/Active controllers, you might want to avoid this version, until you assess the impact it may have...

Cheers,

Rob
Guy Beukes
Advisor

Re: MSA1000 CLI not allowing input of commands

Were did you find version 5.2?

Cheers
Rob Leadbeater
Honored Contributor

Re: MSA1000 CLI not allowing input of commands

Guy Beukes
Advisor

Re: MSA1000 CLI not allowing input of commands

Thanks Rob,

I was been real stupid. The fimware for version 4.48 is available on the main page. My Apologise. Thanks for the help though. Might be back later on this afternoon after I try to flash this MSA. Hopefully it all goes well, now were did I put that Fiber channel card?