Disk Arrays
cancel
Showing results for 
Search instead for 
Did you mean: 

Multiple Device ID's For LUN's

Merlin the happy pig
Occasional Contributor

Multiple Device ID's For LUN's

I have a K370 with two FC cards installed and connected via Brocade switch to an LSI Metastor SAN (Its a pre-badged FC60 apparently - but I feel like the guy whos parents bought him a Lada around here - Everyone else seems to have pukka kit). The problem I have is that whilst I appear to have failover between the primary and alternate device ID's I am able to allocate to the Volume groups, I do not have failover between the controllers on the SAN.

To elaborate - An IOSCAN shows four device ID's for each LUN, two for the FC card with path 8/8 and two for the other FC card 8/12.

Most of the disks are configured to use a prefered SAN controller of "A" but one or two are configured to "B". When controller "B" is failed the SAN reports that the SAN Volumes have been moved to controller "B". However the disks are not available to the HP-UX system anymore under any of the four device ID's.

Example -

LUN 0 shows the following Device Ids under IOSCAN c9t0d0,c12t0d0,c8t0d0 & c11t0d0. I have assigned c9t0d0,c12t0d0 as alternate and primary in a volume group and both of these ID's are assigned to controller "A" (prefered)on the SAN. However the other two device ID's which are assigned to controller "B" and for which I can perform a diskinfo to prove they are the same disks, can not be controlled by LVM. All disks are configured RAID 5.
A Headless Chicken does not stop for a Haircut
4 REPLIES
Bill McNAMARA_2
Occasional Advisor

Re: Multiple Device ID's For LUN's

Send the vgdisplay on the vg just to proove that
it shows up alternate link. With the FC60 the device files
for the lun can be confusing.
Send the ioscan too. Test your links with pvchange -s
/dev/dsk/whatever.

amdsp -a
may give something too.
If the host sees the disks, LVM should work.

(unless you need controller firmware upgrade)

Bill
Iain F. Brown
Valued Contributor

Re: Multiple Device ID's For LUN's

If this LSI array is similar to the FC60 you need to ensure the controllers are in Active/Active mode. ammgr -c AA (set active active)Also autolun transfer may be disabled by a number of underlying problems within the controller. The easiest way to cure this is back off the data and re-initialise controllers amutil - sysWipe and restore data.
Nick Wickens
Respected Contributor

Re: Multiple Device ID's For LUN's

Thanks for the replies guys - unfortunatly the controller appears to be not compatible with any of the FC60 commands or utilities. I am going to do some further testing later this month when I get somedown time and if I resolve will post a reply for any other future unfortunates who get lumbered with an LSI SAN.
Hats ? We don't need no stinkin' hats !!
Bill McNAMARA_1
Honored Contributor

Re: Multiple Device ID's For LUN's

What are the LED states on the controllers?
Your patch levels of the Scsi Pass Thru and
SCSI driver would be interesting too.

Try connecting to the RS232 interface to get status at the back of the controllers.

Later,
Bill
It works for me (tm)