Disk Arrays
cancel
Showing results for 
Search instead for 
Did you mean: 

Nike array problem

Manoj P.U.
Advisor

Nike array problem


Hi, All

My disk array box is giving a strange problem.

In the presentation utility in the place of A0 disk module it shows details of C1 disk module and vise versa.

That means when I check the property of A0 disk module in the right hand side upper corner it says C1 is bounded and enabled. And when I see the property of C1 it says A0 is bounded and enabled.

Another problem is whenever I switch on the disk array it starts rebuilding data on both disk modules.

If anybody can suggest idea to sort out this issue it will be very much helpful to me.

Regards

Manoj
Manoj P.U.
6 REPLIES
Bill McNAMARA_1
Honored Contributor

Re: Nike array problem

what slot was the disk bound in? If you move disks around from one slot to another (within the same lun) without unbinding.. you may see this.

This could cause minor problems in Raid5, but otherwise I woundn't treat it as a problem.. Backup and put the disks in the right place (only remove one at a time and WITH power on) - watch out for rebuilds, you might want to disactivate HS.

Later,
Bill
It works for me (tm)
Manoj P.U.
Advisor

Re: Nike array problem



Hi Bill,

What I meant was in the slot A0 it shows details of C1 disk module and in the slot C1 it shows details of A0 disk module. But these disks are of different Luns not in the same LUN.

Now I will explain you the raid configuration.

There are ten disk modules and 2 LUNS (5 Disks in each LUNS).

After rebuilding the data, disk distribution will be as follow

LUN-0 - RAID5

B0, C0, D0, E0 and C1

LUN-1 - RAID5

A1, B1, D1, E1 and A0


The problem is in every reboot of disk array it finds two disks C1 and A0 were failed and after initializing it start-rebuilding data on these disks automatically.

So while starting array if there is any more disk failure from any LUN may cause in data lose. Since Luns are in RAID5 and there is no HS configured.


Thanks & Rgds

Manoj
Manoj P.U.
Bill McNAMARA_1
Honored Contributor

Re: Nike array problem


Quickly, without reading much!, this is not a good configuration:

LUN-0 - RAID5

B0, C0, D0, E0 and C1

LUN-1 - RAID5

A1, B1, D1, E1 and A0

should be :

Lun 0 all disk X0's
Lun 1 all disk X1's

You will get bottlenecks on the C bus accessing Lun0 and on the A bus accessing Lun1 otherwise. (Maybe this is the resulting configuration of your problem?) did you move disks at all?

Bill
It works for me (tm)
Bill McNAMARA_1
Honored Contributor

Re: Nike array problem

First, make a backup you're happy with.

All maintenance of the array should be done with power on.

Try pulling out the disk C1 and reslotting it.

Can you access the stm tools-info-run to get details on the lun configuration.

Does the UEL show anything in FE mode (ctrl P, shift F E on the presentation screen)

It works for me (tm)
Manoj P.U.
Advisor

Re: Nike array problem


Hi Bill,

Yes, you are exactly right and the configuration was with properly load balanced between the SCSI buses.

That means LUN 0 ??? A0, B0, C0, D0, E0
LUN 1 - A1, B1, C1, D1, E1

This configuration change in the disk distribution occurred after replacing a failed disk module C1.

As such there is no heavy I/O on the LUNS there is no issue in this unbalanced distribution of the disks.

In fact I have tried already the suggestion that you given (reslotting) for both disks C1 and A0 in online.

My only worry is how to stop the rebuilding of disk data on A0 and C1 in the startup of the disk array.

Is there any other suggestion to sort out the issue?



Thanks & Regards,

Manoj
Manoj P.U.
Bill McNAMARA_1
Honored Contributor

Re: Nike array problem

backup,

try pulling out disk A0 and rebooting.

There is obviously a problem with the array config stored on the SP PROM.

You can try to force reload it via "Update SP PROM and Reboot SP" from the SP Menu on Gridmanager. I can't recall if you need to be in FE mode or not.

Open a call also if you have a support contract because of all the timne I worked on nike's I NEVER saw this happen and I saw a lot of stuff..!
It works for me (tm)