Disk Arrays
cancel
Showing results for 
Search instead for 
Did you mean: 

Old Virtual Array Disk Misplaced

Chad Brindley
Regular Advisor

Old Virtual Array Disk Misplaced

Hi,

 

We have an old Virtual Array 7410 and one of the disks is showing as a Misplaced Drive.

 

JA0/D3.

 

I have checked this disk physically and there are no errors.

 

Checking the disk through Storage Works and VirtualRAID state is showing this drive as NOT INCLUDED and not part of Redundancy Group 1 or 2 but 65536.

 

The disk is showing as good when I run an armdsp -a on the the VA.

 

Any idea what might have happened here and how to add it back into the VirtualRAID?

 

Regards,

 

Chad

 

 

P.S. this thread has been moved from HP StoreVirtual / HP LeftHand Storage to Disk > Disk Array - HP forums moderator

 

4 REPLIES
Torsten.
Acclaimed Contributor

Re: Old Virtual Array Disk Misplaced

Maybe the disk was used in another array before, hence it is not included automatically.

Try

armcfg -a ...

to include disk. AFAIR this should help.

 

 

Example:

 

armcfg -D JA2/D5 -a myArray


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
hvhari
HPE Pro

Re: Old Virtual Array Disk Misplaced

could you post the output of "armdsp -a" here?

Regards,
Hari

If this post was useful , click the Kudos Star on the left side to say Thanks!
Chad Brindley
Regular Advisor

Re: Old Virtual Array Disk Misplaced

Hi guys,

 

Sorry for slow response, this thread got moved and for a long time I couldnt reply back.

 

See the attachment output from armdsp -a

 

I have connected to HP StorageWorks Command View SDM and can see the option also to include the disk in here using the GUI but I'm not really sure if this will cause problems, I guess it wont as it was definitely part of the array before.

 

The physical disk hasnt been replaced and is possibly an original from when this array was put in a long time ago.

 

Regards,

 

Chad

 

Torsten.
Acclaimed Contributor

Re: Old Virtual Array Disk Misplaced

Did you try this?

 

armcfg -D JA0/D3 -a covsapva


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!