Storage Boards Cleanup
To make it easier to find information about HPE Storage products and solutions, we are doing spring cleaning. This includes consolidation of some older boards, and a simpler structure that more accurately reflects how people use HPE Storage.
Disk Arrays
cancel
Showing results for 
Search instead for 
Did you mean: 

Options with issues on E200 Raid 5 Array

Paul_637
Regular Advisor

Options with issues on E200 Raid 5 Array

I have a RAID 5 array with 4 x 500Gb SATA disks on an E200 with BBWC (on an ML110).

The host is a VMware 3.5 (installed to a dedicated 160Gb disk) and the RAID 5 array is configured as a single VMFS volume.

I've recently started experiencing failures with the RAID5 array resulting in the VMFS going offline.

On reboot, the SA firmware complains of a previous failiure, stating that the disks have come back online or have been replaced & gives the F1 (disable) or F2 prompt. It's complaining about the disk in slot 3.

I choose F2 and the volume is available once again.

VMware boots, volume remains available for about 5 mins or so (I can browse it and VMs stored on it are starting), then goes offline again.

I reboot once more and this time it says that disks had failed in slots 2 & 3 but are now available again (F1/F2).

I now can't decide what to do next to try to recover the volume. I'll happily purchase 2 replacement disks & replace one at a time but I'm worried that the drive won't have time to rebuild before it goes offline again.

The thing that's also throwing me is that if it's mostly one drive that's causing problems, why, in a RAID5 array, does it not keep going?

The lack of an ACU is throwing me somewhat as I can't properly determine where the issues really lay.

Can anyone suggest a way forward?

Thanks,

Paul
4 REPLIES
Patrick Terlisten
Honored Contributor

Re: Options with issues on E200 Raid 5 Array

Hello Paul,

try update the controller firmware.

Best regards,
Patrick
Best regards,
Patrick
Paul_637
Regular Advisor

Re: Options with issues on E200 Raid 5 Array

Good plan, it was a little out of date, but didn't help unfortunately :(

If I knew just how "corrupt" the volume was, I'd know whether or not it was worth persuing trying to recover what's on it (there are some VMDKs I'd *really* like to recover if at all possible).

Paul
Paul_637
Regular Advisor

Re: Options with issues on E200 Raid 5 Array

Having looked at it some more today, I've seen the first consistency as far as failures are concerened.

Numerous times now the controller has reported one particular disk as "failed" so I bit the bullet and replaced it with another (larger, but I'm not worried about the wasted capacity for now, I just want to get the volume accessible).

However, contrary to all my previous experience with smartarray controllers, now that I've replaced the disk, the array merely complains that the disk is "missing", even with the replacement inserted.

I've always seen such arrays simply kick into to auto-rebuild onto replacement drives. How am I supposed to start the process here? (bearing in mind it's a VMware ESX install).

Also, even though this one disk is currently "missing", surely the R5 volume should still be visible? Not so, no complaints (other than "you should replace this disk) during boot, but the volume doesn't present once booted.

Any suggestions?
Paul_637
Regular Advisor

Re: Options with issues on E200 Raid 5 Array

Re: last post - Stupidity on my part! I'd inadvertently connected the "Drive 2" cable from the /other/ set of 4 cables rather than the original!

Re-cabled correctly and things *SEEM* to be rebuilding! At least it's lasting longer than it has previously.

I have my fingers crossed!!!