Disk Arrays
cancel
Showing results for 
Search instead for 
Did you mean: 

Secure Path and Secure Path Workgroup Edition

CAS_2
Valued Contributor

Secure Path and Secure Path Workgroup Edition


My box uses Secure Path 3.0C as shown by swlist:

CPQswsp A.3.0C.00F.00F HP StorageWorks Secure Path Device Driver and utilities for HSx class of Disk Arrays

I'm planning to upgrade the Secure Path due to some problems (I previously installed QPK June 2006 + superseding patches).

But in web page http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareIndex.jsp?lang=en&cc=us&prodNameId=1825336&prodTypeId=12169&prodSeriesId=471465&swLang=8&taskId=135&swEnvOID=7

there are Secure Path (SP) and Secure Path Workgroup Edition (SP-WE).

What are the diferences ?

In my box , is running SP or SP-WE ?
4 REPLIES
Steven Clementi
Honored Contributor

Re: Secure Path and Secure Path Workgroup Edition

SecurePath is for MA/EMA/EVA storage where SecurePath WE is for MSA storage.

It looks like you need updates for SecurePath (SP), NOT the Workgroup Edition

(this is based on the fact that your driver info mentions "HSx". The MSA is Smart Array based, not HSx.)

My statements are based on a Windows environment. Though I highly doubt that the Workgroup Edition for HP-UX would mean something different, there is that possibility.


Steven
Steven Clementi
HP Master ASE, Storage and Clustering
MCSE (NT 4.0, W2K, W2K3)
VCP (ESX2, Vi3, vSphere4, vSphere5)
RHCE
NPP3 (Nutanix Platform Professional)
Uwe Zessin
Honored Contributor

Re: Secure Path and Secure Path Workgroup Edition

Well, this is in a HP-UX environment. The latest Quickspec at HP's web site dated 10-JUN-2005 says:
""Secure Path v3.0F for HP-UX Workgroup Edition supports HP-UX hosts connected to VA7400/7100, VA7410/7110 storage solutions.""

I have saved an older copy which says:
""Secure Path v3.0C for HP-UX Workgroup Edition supports HP-UX hosts connected to VA 7400/7100, VA 7410/7110 storage solutions.""

Your version is "CPQswsp A.3.0C.00F.00F HP StorageWorks Secure Path Device Driver and utilities for HSx class of Disk Arrays", which is the 'enterprise' edition.
.
CAS_2
Valued Contributor

Re: Secure Path and Secure Path Workgroup Edition

In the URI I provided above, you can download Secure Path 3.0F for HP-UX, but there 5 possible downloads.

The two first ones refer to "Secure Path 3.0F Service Pack 1" ,i.e., an update for 3.0F. As prerequisite, Secure PAth 3.0F must be already installed... Therefore I'm not interested.

But downloads #3 and #4 refers to "Secure Path 3.0F Software Update" and "Secure Path 3.0F Workgroup Edition Software Update".

The prerequisites for download #3 include
# Array Controller Software 8.6, 8.7, 8.8
# Virtual Controller Software, 3.010, 3.014, 3.025
# XL Controller Software, v5.020

I don't know these softwares nor the way I can find out this info from my EVA... BUT ... these three prerequisites are not required for download #4. Thus, if current "Secure Path 3.0C" present in my box is "Workgroup Edition" I won't have to worry about those three prerequisites. This made to start this thread.

But later, I realized that, both, download #3 and download #4 have the same timestamp (18 Nov 2005) and the same size (21.5 MB). Futhermore, the archive names match.

I downloaded both archives and uncompressed... The cksum command reports they are same size and have same checksum. Therefore they are the same software !!!

But why prerequisites are different ? Is it a mistake ?
Which of prerequisite list is wrong ? Are those softwares really required ?


What do you think ?
Steven Clementi
Honored Contributor

Re: Secure Path and Secure Path Workgroup Edition

The Software is what is running on the actual Storage Array. The "firmware".

Array Controller Software = ACS = Runs on MA/EMA Storage Arrays

Virtual Controller Software = VCS = Runs on EVA 3000 and 5000 Arrays

XL = XP Storage (guessing here)


Go with Download #3 since you have an EVA. EVA = HS"V" Controllers = VCS


Steven
Steven Clementi
HP Master ASE, Storage and Clustering
MCSE (NT 4.0, W2K, W2K3)
VCP (ESX2, Vi3, vSphere4, vSphere5)
RHCE
NPP3 (Nutanix Platform Professional)