Disk Arrays
cancel
Showing results for 
Search instead for 
Did you mean: 

SecurePath Gurus: What Should I be Seeing in SPMGR If I Do Load Balancing

Alzhy
Honored Contributor

SecurePath Gurus: What Should I be Seeing in SPMGR If I Do Load Balancing

I already set my Server to do Load Balancing and the following is my spmgr output: (Is this correct?)

Server: xxxhpte3.xyz.com Report Created: Fri, Jun 27 07:37:59 2003
Command: spmgr display
= = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = =
Storage: 5000-1FE1-000C-3B20
Load Balance: On Auto-restore: On
Path Verify: On Verify Interval: 30
HBAs: td0 td1
Controller: ZG04903832, Operational
ZG04706210, Operational
Devices: c11t0d0 c11t0d1 c11t0d2 c11t0d3

TGT/LUN Device WWLUN_ID H/W_Path #_Paths
0/ 0 c11t0d0 6000-1FE1-000C-3B20-0009-0490-3832-0007 4
255/255/0.0.0
Controller Path_Instance HBA Preferred? Path_Status
ZG04903832 no
c3t0d1 td0 no Active
c9t0d1 td1 no Available

Controller Path_Instance HBA Preferred? Path_Status
ZG04706210 no
c5t0d1 td0 no Standby
c7t0d1 td1 no Standby


TGT/LUN Device WWLUN_ID H/W_Path #_Paths
0/ 1 c11t0d1 6000-1FE1-000C-3B20-0009-0490-3832-000E 4
255/255/0.0.1
Controller Path_Instance HBA Preferred? Path_Status
ZG04903832 no
c3t0d2 td0 no Available
c9t0d2 td1 no Active

Controller Path_Instance HBA Preferred? Path_Status
ZG04706210 no
c5t0d2 td0 no Standby
c7t0d2 td1 no Standby

Hakuna Matata.
4 REPLIES
Bharath_Pingali
Trusted Contributor

Re: SecurePath Gurus: What Should I be Seeing in SPMGR If I Do Load Balancing

Load balancing is sending I/O on 2 paths (in this case).

Your output is incorrect.


Please see the display in the file attached, that the controller has 2 active paths with load balancing ON.
Alzhy
Honored Contributor

Re: SecurePath Gurus: What Should I be Seeing in SPMGR If I Do Load Balancing

Barath,

Thanks for the info.

Okay.. I assume our Storage Folks need to have this set on the HSG80 controllers - right? Any idea which menu tree, command they need to do?

From the server end, I'm already set to load-balance ON...

Shukria!
Hakuna Matata.
Bharath_Pingali
Trusted Contributor

Re: SecurePath Gurus: What Should I be Seeing in SPMGR If I Do Load Balancing

Hi,

Load balancing is done on the server / HBA side.

Can you provide me the Securepath version? OS ver?

Spmgr set ???b on (will enable for all connected storage on the server)
Or
Spmgr set ???b on wwnn

Note ??? There could be few more commands after this like
Spmgr update / ioscan /insf ???e

This will enable the ???load balancing???. The I/O stream will use all the HBAs available to it .

Ex. Config
2 HBAs
2 switches
1 storage

2 cables will be going from 2 HBAs to 2 switches. 2 cables from each switch to storage (4 cables total).

With the above config you will be seeing 4 paths under securepath. 2 paths from each controller.

TGT/LUN Device WWLUN_ID H/W_Path #_Paths
0/ 0 c42t0d0 xxxx-xxxx-xxxx-xxxx-xxxx-xxxx-xxxx-xxxx 4
255/255/0/0.0
Controller Path_Instance HBA Preferred? Path_Status
ZGxxxxxxxx no
c4t0d5 td0 YES Active
c18t0d5 td1 YES Active

Controller Path_Instance HBA Preferred? Path_Status
ZGxxxxxxxx no
c6t0d5 td0 no Standby
c20t0d5 td1 no Standby


By default securepath uses only one of the paths for I/O. When load balancing is enabled, it chooses 2 paths ( you will have 2 paths as active after LB is ON ) from the same controller for I/O ( I/O is split or spread across the HBAs and paths ).

You should be seeing 2 active paths.


Storage: xxxx-xxxx-xxxx-xxxx
Load Balance: On Auto-restore: Off
Path Verify: On Verify Interval: 30
HBAs: td0 td1
Controller: ZGxxxxxxxx, Operational
ZGxxxxxxxx, Operational
Devices: c42t0d0 c42t0d1 c42t0d2

This above part has the right info on load balancing , but for some reason I don???t see the same effect on the Luns in your config.

Send me more info on the config. All I can tell you is that load balancing is not working in your config or its working and its not being displayed correctly.


-BP
Alzhy
Honored Contributor

Re: SecurePath Gurus: What Should I be Seeing in SPMGR If I Do Load Balancing

On my example, the platform is HPUX 11i on an rp7410. I also have Solaris 8 that is behaving similarly. Both are using SecurePath 3.0b.

I've tried on both HP and SUN the very spmgr commands to enable load balancing but to no avail. On HP I did spmgr update and rebuilt the kernel and rebooted. On Solaris... rebooted -r as well.

Could it be that on the HSG80 there also needs to be some settings? Our HSG80 folksy are new to UNIX and are more proficient with OpenVMS connections...

Hakuna Matata.