Storage Boards Cleanup
To make it easier to find information about HPE Storage products and solutions, we are doing spring cleaning. This includes consolidation of some older boards, and a simpler structure that more accurately reflects how people use HPE Storage.
Disk Arrays
cancel
Showing results for 
Search instead for 
Did you mean: 

Server doesn't properly recognize lun

rock_8
Occasional Visitor

Server doesn't properly recognize lun

We are trying to bring a new server online and attach it to an EMC Clariion. But we cannot get the server to properly recognize the new lun.

The server is an rp5470 and is running HP UX 11.0.

When we attach the lun, we get the following output from the ioscan and diskinfo:

#ioscan -fnC disk
Class I H/W Path Driver S/W State H/W Type Description
==========================================
disk 5 0/2/0/0.106.6.19.0.0.1 sdisk CLAIMED DEVICE DGC CX400WDR5
/dev/dsk/c6t0d1 /dev/rdsk/c6t0d1
disk 6 0/4/0/0.116.6.19.0.0.1 sdisk CLAIMED DEVICE DGC CX400WDR5
/dev/dsk/c7t0d1 /dev/rdsk/c7t0d1

# diskinfo /dev/rdsk/c6t0d1
SCSI describe of /dev/rdsk/c6t0d1:
vendor: DGC
product id: CX400WDR5
type: direct access
size: 20971520 Kbytes
bytes per sector: 512

# diskinfo /dev/rdsk/c7t0d1
SCSI describe of /dev/rdsk/c7t0d1:
vendor: DGC
product id: CX400WDR5
type: direct access
size: 0 Kbytes
bytes per sector: 0

Yet, if we move the lun to an existing server, we get the results we want:

# ioscan -fnC disk
Class I H/W Path Driver S/W State H/W Type Description
==========================================
disk 12 0/2/0/0.116.4.19.0.0.2 sdisk CLAIMED DEVICE DGC CX400WDR5
/dev/dsk/c10t0d2 /dev/rdsk/c10t0d2
disk 16 0/5/0/0.106.4.19.0.0.2 sdisk CLAIMED DEVICE DGC CX400WDR5
/dev/dsk/c11t0d2 /dev/rdsk/c11t0d2

# diskinfo /dev/rdsk/c11t0d2
SCSI describe of /dev/rdsk/c11t0d2:
vendor: DGC
product id: CX400WDR5
type: direct access
size: 20971520 Kbytes
bytes per sector: 512

# diskinfo /dev/rdsk/c10t0d2
SCSI describe of /dev/rdsk/c10t0d2:
vendor: DGC
product id: CX400WDR5
type: direct access
size: 20971520 Kbytes
bytes per sector: 512
1 REPLY
rock_8
Occasional Visitor

Re: Server doesn't properly recognize lun

i ended up downloading the emc installation guide for HP UX :-).

based upon that, i changed the initiator type to to "HP auto trespass" and failover mode "0".

That made the new server happy. i'm still not sure why it was recognized by the old server.