Disk Arrays
cancel
Showing results for 
Search instead for 
Did you mean: 

Smart Array 5300 raid0 bad write perfomance

Puppetfreek
Occasional Contributor

Smart Array 5300 raid0 bad write perfomance

Hi,
I've just bought a Smart Array 5300 with 128mb ram. I've installed 3 SCSI drives (Seagate ST3128451LW (U160 15k), 2 * IBM IC35L018UWPR15-0 (U160 15k)). I've configured them as a 0 array.

My system is:
Amd XP2000+
Asus A7V600-X
1,3Gb ram
Windows 2000 SP4

The problem I've got is that the write perfomance is really bad. I've tested it with ATTO Disk benchmark (Transfer size 1024 - 1024, total length 4mb, queue depth 4), and the results I've got is:

49.652 in write
100.456 in read

I've also tested this in Hd Tach, where i've got a 33mb/s write perfomance.

This perfomance is very bad, even slower then all my old IDE-drives. So, I thought that the write cache wasn't enabled. But I can't enable it with Device manager. I've found a document in the "troubleshooting documents" where my problem was described. But, I couln't perfom that task written there.

In the Compaq Array Configuration I get the following error:

You cannot modify the write cache status of any drive, because either there are no drives attached to the controller or none of the drives attached to the controller have a reliable write cache.

I thought that was because I got the following error when I've started the program "Controller slot information will be unavailable during this ACU session because the Compaq System Management Driver is not installed on the server. All slot information will appear as "Unknown".

If you want to see slot information, install the Compaq System Management Driver.".

But, when I've tried to install the drivers, it just says I don't need them.

But after some more research I've found that you can change it from the Command line (HPACUCLI).

But there I got the following error:

Error: This operation is not supported with the current configuration. Use the
"show" command on devices to show additional details about the
configuration.

This is my configuration:

Controller Smart Array 5300 in Slot 3
Bus Interface: pci
slot: 3
serialnumber: XXXXXXXXXXXX
RAID 6 (ADG) status: False
Controller Status: OK
Chassis Slot: 1
Hardware Revision: Rev A
Firmware Version: 2.92
Rebuild Priority: Low
Expand Priority: Low
Surface Scan Delay: 15 sec
Cache Board Present: True
Cache Status: OK
Accelerator Ratio: 50/50 (read/write)
Read Cache Size: 56 MB
Write Cache Size: 56 MB
Total Cache Size: 112 MB
Battery Backed Cache Size: 112 MB
Non Battery Backed Cache Size: 0 MB
Battery Pack Count: 2
Battery Status: OK


So, what should I do? Please, help me, I can't figure out how to enable the disk drive cache, that maybe can solve the problem with the bad write perfomance.

Best regards,
Mathias
1 REPLY
e4services
Honored Contributor

Re: Smart Array 5300 raid0 bad write perfomance

You can not do thoughs things because the system is not a Proliant. As for the performance, it seems all in line. This is a RAID after all. Use a standard SCSI U320 controller
Hot Swap Hard Drives