Disk Arrays
cancel
Showing results for 
Search instead for 
Did you mean: 

Smart array 641 slow expanding

NXS
Valued Contributor

Smart array 641 slow expanding

If have 2 disk of 36 GB mirror (linux EL 3 OS diska) and 3 x 143 GB raid 5 disks (data disks). Now I've added an new 143 GB data disk in to the existing array and after 6 days he is still expanding.
I installed the latest acu (proliant tools 7.1.1) And I did this expand on a working linux fileserver with Rebuild Priority on Low and Expand Priority Low.

Is this normal that it takes so long? And the progress bar is switching from 96 to 100 to 92 to 94 to 100.

extra info
I'm a problem with an array 641 and expanding a configured raid 5 array with a 143 GB disk in raid 5. So total array is 575 GB. I allready had a logical volume of 286 GB on this array and created an new of 143 GB. Online on RHEL 3 with expanding and rebuiling proirity on low. It allready takes about 6 days and he is still expanding
3 REPLIES
KurtG
Regular Advisor

Re: Smart array 641 slow expanding

I'm not able to estimate how long it should take, but the setting slow menans really SLOW. I belive that the slow means that it would NOT expand unless there are virtually no system i/o pending. On a live system I guess this would be very seldom.

I recomend that you try changeing the the expand priorety to medium.

KurtG
NXS
Valued Contributor

Re: Smart array 641 slow expanding

Can I still stop this once it started? And on a running mmachine? Can I cahang the values online?
But what i find strange is that the progress bar is goinig to 100 % and the goes to 90%
KurtG
Regular Advisor

Re: Smart array 641 slow expanding

As I remember this controller it shold be possible to change expansion priority "On-the-fly".

I have turned off servers, done reeboots and so on and I have never had any problem during expansion.

However, if in doubt, call HP. It's allways possbile that there might be a firmware issue related to disk and/or controller. If there are an issue, they should be able to recomend a way out of it.

I recomend that you try to change expansion priority first. It this does not helt, call HP.

Good luck!

KurtG