Disk Arrays
cancel
Showing results for 
Search instead for 
Did you mean: 

System board died in Proliant 2500, logical drives grief

Ayman Altounji
Valued Contributor

System board died in Proliant 2500, logical drives grief

Hello Everyone!

Apologies for the formatting in advance!

I've recently inherited this problem: Our rack mounted Proliant 2500 server with a Smart-2/P array controller recently lost its system board (in the troubleshooting process we fried a new power supply before changing the diagnosis to the system board). The card runs 2 (36GB) hard drives internally on the Proliant 2500 and 3 (36GB) hard drives on an external storage array. The five drives are in one Raid 5 array, and broken into two logical volumes.

In NT 4.0 disk administrator, we can see the two logical volumes appearing as disk 0 and disk 1. However they appear as:
Disk 0 (69180 MB), Free Space (82341 MB), Unknown (0 MB), Free Space (183015 MB), Unknown (0 MB), OS/2 Boot Manger (953965 MB). Disk one is identical in the partitioning but overall disk size is reported as 69746 MB.

In the Compaq Array Configuration utility the following message pops up:

Background parity initialization is currently queued or in progress on Compaq Smart-2/P Controller in Slot 4 on the following logical drives:

Logical Drive 1

This is a normal operation that is necessary to initialize logical drives that have a fault tolerance with parity. If background initialization is queued, it will start when I/O is performed on the drives. When background parity initialization completes, the performance of the logical drives will improve (15645)

I'm really not reassured by the message as I don't think the data is being regenerated (the drives do not seem to be whirring and clicking like they would if data is being read and written). I believe the "partition" information of the drives is messed up and when we look at it in the NT Disk administrator, we are seeing the striping from raid 5 (just a guess).

My contribution to the problem was to upgrade the system board bios to the most recent version (as the system board was replaced... it had not been flashed to the 12/01/1999 bios and was using the 06/28/1999 bios)

Another possibility is that the system board fried the Smart-2/P array controller card (or at least confused it). If that's the case, could I somehow get a utility to pull array configuration data off of disk? Although, I think the card is ok, as everything from the hardware side looks ok (with the exception of the weird partition table).

I'd sure like to recover the data and at this point would welcome a contact number from Compaq or any suggestions.