Disk Arrays
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to create virtual disk on a HSG80 controller array

SOLVED
Go to solution
Shashi Kiran_2
Occasional Visitor

Unable to create virtual disk on a HSG80 controller array

Hi,

I am trying to configure a HSG80 (MA8000) storage array from a Win2k system. I select icon to start "add virtual disk wizard" from StorageWorks CC HSG80 GUI. This takes me through all the steps of selecting RAID type and physical disks etc. without any errors. But in the end it DOES NOT display the newly created virtual disk icon in the top panel. Due to this I am not able to see the array targets on a fibre channel fabric or from a host machine.
Please explain what's happening and the possible workarounds.

Thanks!,
Shashi
4 REPLIES
Mike Naime
Honored Contributor
Solution

Re: Unable to create virtual disk on a HSG80 controller array

Use the CLI. Not the GUI.

You should be able to look at the Raidset and presentation on the MA8000 by connecting the serial cable between your laptop, and the HSG CLI serial port.

This will verify for you that you created the raidset, and that it is being presented to your systems.

Also, you can verify that the connections for your server are present on the HSG. I.E. match the WWID's of the server to the WWID's of the connections on the HSG.
VMS SAN mechanic
Shashi Kiran_2
Occasional Visitor

Re: Unable to create virtual disk on a HSG80 controller array

Hi Mike Naime,

I was able to successfully configure a mirrorset using CLI. I am really disappointed by the implementation of GUI, the version that I have supports only a subset of features available through CLI. And these supported features (for eg. creation of virtual disk) are not completely reliable.
I am having one more problem, after creating the virtual disk through CLI. The disk unit(D1) is visible only through ports 1 & 3. The controllers are configured in Multiple-Bus Failover mode.

Thanks for the help!,
-Shashi
Mike Naime
Honored Contributor

Re: Unable to create virtual disk on a HSG80 controller array

Do you have reduandant SAN fabrics and dual HBA's on your server? Or are you single HBA/fabric only?

In my setup, All of the HSG's have ports 1 & 3 connected to my "RED" fabric, and ports 2 & 4 are connected to my "BLUE" fabric.

It sounds like you only have one fabric zoned for this server/HSG combo. At the CLI, where you able to see all 4 connections/wwid's for the server in question

Here is one of our servers that I renamed the connection on. Notice that I see each WWID through the same port on THIS and OTHER controllers.

CLSTR3B1 WINNT THIS 1 101000 OL this 0
HOST_ID=2000-0000-C925-B8E6 ADAPTER_ID=1000-0000-C925-B8E6

CLSTR3B2 WINNT THIS 2 101000 OL this 0
HOST_ID=2000-0000-C924-1088 ADAPTER_ID=1000-0000-C924-1088

CLSTR3T1 WINNT OTHER 1 101000 OL other 0
HOST_ID=2000-0000-C925-B8E6 ADAPTER_ID=1000-0000-C925-B8E6

CLSTR3T2 WINNT OTHER 2 101000 OL other 0
HOST_ID=2000-0000-C924-1088 ADAPTER_ID=1000-0000-C924-1088
VMS SAN mechanic
Shashi Kiran_2
Occasional Visitor

Re: Unable to create virtual disk on a HSG80 controller array

Yes let me tell something about my configuration- I have iSCSI driver running on host machine and an IP-to-FC bridge to connect to FC SAN fabric.
The HSG80 configuration was okay and the problem was the existing connections, removing it did the trick for me. It may be relevant to note here that "show connections full" on CLI always gives out error message "Error - Possible communication loss with subsystem.". I had to view connections from GUI and remove the same using CLI!.

Thanks again,
-Shashi