Disk Arrays
cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrading EVA-5000 to VCS 4.0 with SecurePath and Recabling

SOLVED
Go to solution
Ian Dennison_1
Honored Contributor

Upgrading EVA-5000 to VCS 4.0 with SecurePath and Recabling

I am planning to upgrade the VCS on my EVA-5000 from 3.028 to 4.004. We are running SecurePath 3.0E (to be upgraded to 3.0F beforehand) on the Windows and HP-UX Servers that are connected.

I have downloaded the impact asessment checklist for the 3.028 to 4.004 upgrade so I already know what versions of software are supported and what recabling actions are required.

The checklist refers to the "configuration guide" for HP-UX HBA compatability - can anyone give me a link or a keyword to search on?

What I also need to know is IF (Note the conditional there, this is hypothetical!) I continue to use SecurePath 3.0F after the 4.004 upgrade, what impact does the recabling have, and what remedial action (if any) is needed to rescan disks afterwards?

Also, what is the potential migration method from using SecurePath 3.0F to PVLinks?

IMPORTANT NOTE: Any posts referring to recommendations to not use SecurePath after the VCS upgrade will be given zero points. I am upgrading a multi-EVA, multi-server, multi-OS environment that cannot be done with a "big bang".

Share and Enjoy! Ian
Building a dumber user
5 REPLIES
Uwe Zessin
Honored Contributor
Solution

Re: Upgrading EVA-5000 to VCS 4.0 with SecurePath and Recabling

OK, I will risk zero points ;-)

Neither the Secure Path version installed on Windows nor the "Secure Path for active/passive arrays" on HP-UX will work after the upgrade to VCS V4 !!

This upgrade intentionally changes the SCSI inquiry string from HSV110 to HSV111 exactly to prevent Secure Path (for active/passive arrays) from filtering the SCSI LUNs after the upgrade.

On Windows, you do need to install the Full-Featured MPIO for VCS V4. If Secure Path is recent enough, you should be able install both versions in parallel before the upgrade happens.

The same applies for a recent-enough version of Secure Path V3.0 for HP-UX: you can run the active/passive (spmgr) and the active/active (autopath) versions in parallel.

The Secure Path A/A version for HP-UX does not create a new pseudo-controller. It does not matter if you use SP-AA or PVlinks - in both cases you add all possible paths for a PV to the volume group.
I'm not a HP-UX expert, but I think you have to export the volume groups before the upgrade and then import with the new paths.
.
Ian Dennison_1
Honored Contributor

Re: Upgrading EVA-5000 to VCS 4.0 with SecurePath and Recabling

Uwe,

OK, such a clear and informed answer is well worth more than zero points! (Even if its not the answer I was looking for!)

Ah well, looks like the big bang has to go ahead after all.

Thanks, Ian
Building a dumber user
IBaltay
Honored Contributor

Re: Upgrading EVA-5000 to VCS 4.0 with SecurePath and Recabling

Hi,
1. why not using the vcs 4.100 to start the big bang?
http://forums11.itrc.hp.com/service/forums/questionanswer.do?threadId=1302156
2. why not choosing the latest but only AP firwmare 3.110 to not start the bigbang - this can be commited fully online with the existing
versions of the multipathing


the pain is one part of the reality
Uwe Zessin
Honored Contributor

Re: Upgrading EVA-5000 to VCS 4.0 with SecurePath and Recabling

> (Even if its not the answer I was looking for!)

I'm sorry, I understand that is not the answer you wanted to hear. Well, I'm used to bring bad news to other people...

> Ah well, looks like the big bang has to go ahead after all.

It is not such a _big_ one if you bring your servers into kind of 'coexistence mode' by installing both, active/passive and active/active multipath solutions.
.
Ian Dennison_1
Honored Contributor

Re: Upgrading EVA-5000 to VCS 4.0 with SecurePath and Recabling

Thanks all for contributions. Ian
Building a dumber user