Disk Arrays
cancel
Showing results for 
Search instead for 
Did you mean: 

VCS v3.028 to v4.004 easy migration path

VCS v3.028 to v4.004 easy migration path

For those of you out there, like me, who are going to do a 3.028 to 4.004 upgrade in the near future I think I have an easy migration path to offer you.

Current migration:
1. Change FC cabling from cross-over to straight through, and re-zone, during upgrade.
2. Uninstall SecurePath from all servers and install MPIO full during the upgrade.

Now, SecurePath doesn't support v4, due to active/active, MPIO full doesn't support v3, the Device Specific Module is only for HSV111 (v4 Controller), and MPIO basic only supports the DSM for HSV110 (v3 Controller). So it seems all servers would need SecurePath uninstalling (1 reboot), install MPIO full (another reboot) to all the servers on your EVA, all while tending to the HP engineer performing the upgrade, switching cables and re-zoning. Got to love Microsoft and HP for making it easy!

What I have discovered however is that the MPIO install has two components, the Microsoft MPIO framework and the HP DSM. If you install the MPIO basic the framework and the DSM for a HSV110 (v3 Controller) will be installed. If you then install the MPIO full as well, the installer will update the framework to the latest version, leave the HSV110 DSM and install the HSV111 (v4 Controller) DSM.

This will then work with the HSV110 DSM on VCS3.028, and presumably change over to using the HSV111 DSM once the VSC has been upgraded to 4.004. To make it simpler I am currently investigating whether a HSV110 (v3)will work in straight through cabling mode, if so the cable switch-over and re-zoning can be done prior to the upgrade, leaving a reboot (shutdown and restart) off all server on the SAN during the upgrade, and making the engineer a cup of tea.

Will post results once the upgrade is complete.

James
4 REPLIES
Tom O'Toole
Respected Contributor

Re: VCS v3.028 to v4.004 easy migration path


Is this assuming you are a microsoft only shop?
Can you imagine if we used PCs to manage our enterprise systems? ... oops.

Re: VCS v3.028 to v4.004 easy migration path

We have an HPUX server as well, however Secure Path v3.0F SP1 supports both releases of code.

James
Raymond Kales
Occasional Visitor

Re: VCS v3.028 to v4.004 easy migration path

Hi James,

Did it work? We are in the same situation and trying to figure out a migration plan with the least ammount of down and work time.

Regards,

Raymond
Alzhy
Honored Contributor

Re: VCS v3.028 to v4.004 easy migration path

"We have an HPUX server as well, however Secure Path v3.0F SP1 supports both releases of code."


BUT, you need to have BOTH versions of SecurePath (Autopath and CPQswsp) installed - right?

Not too many people know this but since SeurePath 3.0D, SeurePath contains 2 software versions.. one for active-active (aka AutoPath) and the older Compaq descended SecurePath software... Both needs to be installed BEFORE you perform your VCS upgrade.
Hakuna Matata.