Disk Arrays
cancel
Showing results for 
Search instead for 
Did you mean: 

array configuration lost ?

Ayman Altounji
Valued Contributor

array configuration lost ?

Configuration: D360 with Smart 431 controller and a 4214R Enclosure with 4 Drives in RAID-5 configuration and 1 hotspare. The internal controller has 2 disks using RAID-1 (booting from here)

When we were having problems with the enclosure (fixed by swapping the PS and cables) we attached the disks on the internal array controller of the D360.

When we attached the enclosure back to the Smart 431 we got error 1785 saying the controller is not configured. The controller refuses too see the array although it can see the disks in the enclosure. The diagnostics says "Swapped cables or Configuration error detected ..."

When connect the enclosure back to the internal controller everything is o.k. again ...

I will upgrade the firmware of the controllers tomorrow morning. Would this solve my problem, or could it create more ?
1 REPLY
Mark Cloutier
Respected Contributor

Re: array configuration lost ?

One thing you could try is to physically remove the 4214R from the 431 smart array controller. Reboot the server with a SmartStart cd in and when the menu appears run the ARRAY CONFIGURATION UTILITY. Under Controller Selection please choose the 431 smart array controller. Delete the existing array uinder there. Save changes and shut down the server. Plug the 4214R back into the 431 and power on the server. When it initializes the 431 it should say new logical drive found. It should be automatically updated.
Now don't worry about your data on the 4214R. With it being unattached it will keep the Raid in the RIS sector of the hard drives.
Updating will not make things worse.
I hope this helps. Please keep me posted.
We are here for a good time, not a long time!