Storage Boards Cleanup
To make it easier to find information about HPE Storage products and solutions, we are doing spring cleaning. This includes consolidation of some older boards, and a simpler structure that more accurately reflects how people use HPE Storage.
Disk Arrays
cancel
Showing results for 
Search instead for 
Did you mean: 

secure path eva400 asm

Eduardo Andrade
Occasional Advisor

secure path eva400 asm

Hello i have a rp3440 with eva 4000 in cluster with orale rac and asm. Secure path 30f sp2.
when disconect one hba the database is down and the syslog "autopath failed rerouting"
5 REPLIES
Sameer_Nirmal
Honored Contributor

Re: secure path eva400 asm

I assume here setup and configuration is done properly.

Check if the autopath monitor process is running. What do you see in autopath display command?
Murat SULUHAN
Honored Contributor

Re: secure path eva400 asm

Hi

Is there any log about problem in /var/opt/resmon/log/event/log

Which SP option did you select while installation (active/active, active/passive)

EVA4000 firmware release ?

Best Regards
Murat
Murat Suluhan
Eric SAUBIGNAC
Honored Contributor

Re: secure path eva400 asm

Hi Eduardo,

Can you verify that you can see the devices ASM uses with "autopath display" ? I think you should see devices correctly since AUTOPATH send syslog messages.

In case "autopath display" shows nothing, do "autopath discover ON", in order autopath makes automatic discovery at boot time, the do "autopath discover".

How many path per LUN can you see with "autopath display" ? With 2 HBAs you should see 4 paths. I took a look at your syslog file and we can see that only two paths are down. That's a normal beahavior if you loose one HBA. So if you have 4 path per LUN it should still work.

Are you sure that owner/group of special disk files you use with asm is something like oracle/dba or at least rw for every body ?

Hope this will help

Eric

Eduardo Andrade
Occasional Advisor

Re: secure path eva400 asm

Hi
The autopath display, and atach the owners
HPswsp Version : A.3.0F.02F.02F
=================================================================
Auto Discover : ON
=================================================================
Array Type : EVA-AA
Array WWN : 5000-1FE1-500C-C040
Read Optimize : ON
Path Verification Period : 00:10
=================================================================
Lun WWN : 6005-08B4-0007-41EB-0000-8000-0152-0000
Virtual Device File : /hpap/dsk/hpap9
Load Balancing Policy : Round Robin
Lun Timeout : Infinite Retry (-1)
=================================================================
Device Path Status
=================================================================
/dev/dsk/c4t0d1 Failed
/dev/dsk/c6t0d1 Failed
/dev/dsk/c8t0d1 Active
/dev/dsk/c10t0d1 Active
Eric SAUBIGNAC
Honored Contributor

Re: secure path eva400 asm

First, we can see that failed paths correspond exactly to the warnings in your syslog file.

In this situation, i would first verify that autopath works well with a dd on a failed path, someting like "dd if=/dev/rdsk/c4t0d1 of=/dev/null bs=1024k count=10". You should have no error though c4t0d1 is failed.

Can you check this ?