Disk Arrays
cancel
Showing results for 
Search instead for 
Did you mean: 

spmgr: Running "display" core dumps

Paul Redman
Occasional Advisor

spmgr: Running "display" core dumps

Folks,

I'm on a HP-run training course at the moment and us Unix bods here are having trouble running spmgr ....

root@c012p20b[bin] spmgr display
/usr/lib/dld.sl: Unresolved symbol: pthread_mutex_lock (code) from spmgr
Abort(coredump)

Has anyone seen anything like this before? I've had a 30min scoot around the internet and the only clues I've uncovered so far have been at ....

http://hpux.hp.sys.comp.newsgrouptopics.com/236/securepath+on+hp-ux:+missing+libpthread.1+pthread_mutex_create+call/

.... and some use of the chatr command. The main clue at the moment seems to be the libraries and/or their paths. Am I on the right track?

Btw, the spagent is running okay.

Many thanks in advance,
Paul
1 REPLY
Alex Georgiev
Regular Advisor

Re: spmgr: Running "display" core dumps

The only thing I can think of off the top of my head is to make sure that you have the right version of SecurePath installed.

Make sure that you don't have 64 bit version installed on a 32 bit machine, or vice versa. Make sure that you don't have more than one spmgr executable somewhere in your path...

Other than that I can't think of anything else. spagent isn't your problem for sure... The spmgr command can't even "get off the ground", so its a compilation or a library path problem.

I'm assuming that you didn't compile spmgr yourself, and you didn't mess with the library paths or the loader, so it's most likely a version problem. You can always reinstall, I suppose. Sorry that I can't give you more than that.

HTH!