Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

All EMC symcli commands are taking a long time

Sri123
Advisor

All EMC symcli commands are taking a long time


HI All,

All the EMC symcli commands are taking a long time to give the output in the server.

For example, below command takes about 7 to 8 minutes.

/usr/symcli/bin/syminq

btprod@DIC:/ # uname -a
HP-UX btprod B.11.11 U 9000/800 1396970935 unlimited-user license


Kindly let me know if any further details are required and how to fix this issue.



Thanks in Advance!
Sridhar
7 REPLIES
Anshumali
Esteemed Contributor

Re: All EMC symcli commands are taking a long time

1. Only from one host or all the hosts connected with this storage?
2. What SYMCLI version you got?
3. Did you try cleaning up old DB files/removing lock and symcfg discover to check if it helps.(most of the time this will fix)

/var/symapi/db # ls -ltr
-rw-r--r-- 1 root sys 10694724 Jan 13 01:11 symapi_db.bin
-rw-r--r-- 1 root sys 0 Jan 13 01:11 symapi_db.bin_xlock
Dreams are not which you see while sleeping, Dreams are which doesnt allow you to sleep while you are chasing for them!!
Sri123
Advisor

Re: All EMC symcli commands are taking a long time


Hi Anshumali,

Thanks for the reply.


1. Only from one host or all the hosts connected with this storage?

Only from one host

2. What SYMCLI version you got?

btprod@DIC:/ # swlist | grep -i symcli
SYMCLI V7.1.1.0 EMC Data Storage Systems Private Limited
SYMCLI V7.1.1.0 EMC Data Storage Systems Private Limited


3. Did you try cleaning up old DB files/removing lock and symcfg discover to check if it helps.(most of the time this will fix)

btprod@DIC:/var/symapi/db # ls -ltr
total 13792
-rw------- 1 root sys 1104979 Nov 27 2007 symapi_db.bin.old
-rw-r--r-- 1 root sys 0 Nov 11 15:26 symapi_db.bin_xlock
-rw------- 1 root sys 5923960 Nov 11 15:27 symapi_db.bin
-rw-r--r-- 1 root sys 17558 Jan 19 15:03 storapid_topology.xml



Let me know How to remove lock and run symcfg discover. Can i move this old file which is present?


Thanks in Advance,
Sridhar
Anshumali
Esteemed Contributor

Re: All EMC symcli commands are taking a long time

1. Rename below 2 files using "mv"
-rw-r--r-- 1 root sys 0 Nov 11 15:26 symapi_db.bin_xlock
-rw------- 1 root sys 5923960 Nov 11 15:27 symapi_db.bin

2. #symcfg discover (give it some time to complete)
3. #ls -ltr (just to see they are created again)
4. #syminq, sympd list to check if its resolved.
Dreams are not which you see while sleeping, Dreams are which doesnt allow you to sleep while you are chasing for them!!
Sri123
Advisor

Re: All EMC symcli commands are taking a long time

Hi,

I did that, files were re-created but the problem seems to be still there.

btprod@DIC:/var/symapi/db # ls -ltr
total 16624
-rw------- 1 root sys 1104979 Nov 27 2007 symapi_db.bin.old
-rw-r--r-- 1 root sys 0 Nov 11 15:26 symapi_db.bin_xlock.20012011
-rw------- 1 root sys 5923960 Nov 11 15:27 symapi_db.bin.20012011
-rw-r--r-- 1 root sys 17575 Jan 20 10:33 storapid_topology.xml
-rw-r--r-- 1 root sys 0 Jan 20 10:33 symapi_db.bin_xlock
-rw-r--r-- 1 root sys 1445680 Jan 20 10:34 symapi_db.bin


Thanks,
Sridhar
Anshumali
Esteemed Contributor

Re: All EMC symcli commands are taking a long time

May be time to log a call with EMC unless you get more responses here..
Dreams are not which you see while sleeping, Dreams are which doesnt allow you to sleep while you are chasing for them!!
Rita C Workman
Honored Contributor

Re: All EMC symcli commands are taking a long time

You might try also posting this thread on EMC's Support Forum at http://powerlink.emc.com

Did you recently upgrade SolEnabler? You might try stopping the agents on this server and reinstalling them from the ECConsole.

Regards,
Rita
Kris_Knigga
Trusted Contributor

Re: All EMC symcli commands are taking a long time

I know I'm late to this particular party, but for the sake of Googlers, this issue can sometimes be seen when using a version of Solutions Enabler that supports IPv6 (I think that got added somewhere in the version 6.X era, but I don't remember off the top of my head).

 

Make sure there is an 'ipnodes' database listed in nsswitch.conf.  (http://nixdoc.net/man-pages/hp-ux/man4/nsswitch.conf.4.html).  Basically, the Solutions Enabler commands that support IPv6 try to make some call that tries to resolve an IPv6 name, but with no way to do they just hang until something times out.

 

There's a knowledgebase article on EMC's Powerlink about this, but I don't have access to Powerlink right now in order to look it up.


Kris Knigga