Disk Enclosures
Showing results for 
Search instead for 
Did you mean: 

Armserver problem

Go to solution
Bert Kamps
Frequent Advisor

Armserver problem


Yesterday i had to shutdown a HP 9000 server and the HPC2400 RAID. First i just did a shutdown -h now on the server, and then turn the switch off.
I turned the raid system off by pushing the power button, and it shutdown without errors.

Now when i start the server, i can access the raid. But the status display says SYSTEM WARNING, and LOG FULL...

But when i look in sam, i don't get any info about the raid... So i thought there is something wrong with the ARMSERVER.
The ARMSERVER is running, but when i check syslog it says:

May 4 09:43:41 enubtdc1 syslog: ArmServr Started
May 4 09:55:14 enubtdc1 LVM[10060]: /sbin/lvlnboot -v vg00
May 4 09:55:15 enubtdc1 LVM[10063]: /sbin/lvlnboot -v vg00
May 4 09:59:24 enubtdc1 syslog: su : + 0 root-root
May 4 10:03:10 enubtdc1 syslog: ArmServr: osctrlr::ServerLock Unable to obtain
server lock, lockf rc = -1, errno = 13
May 4 10:03:10 enubtdc1 syslog: ArmServr Exited

Can someone help, please? :)

Thanksin advance!
Insu Kim
Honored Contributor

Re: Armserver problem

First of all, ARMServer is associated with HP AutoRAID.
You stated HPC2400 array and I wonder that you have CASCADE, a out-of-date disk array or HP AutoRAID.

If you're using CASCADE disk array, try to apply the latest AutoRAID patch.

I found a hit connected with CASCADE (HPC2400) in the patch text.

Never say "no" first.

Re: Armserver problem

True the C2400 is our older Cascade product but the autoraid/ARMserver software does leverage from some of the C2400 files. Only autoraid has the display showing Warning: Logs Full so I will assume it is autoraid you are talking about. The syslog info regarding server lock makes me suspect you have multiple hosts attached to your autoraid. It is possible to set or lock one host to record log info but if that host goes down the ownership of logging will go to the next host still in touch with the array. A Log Full error is mostly informational and in this case may have resulted from the way you shut down. I will attempt to attach a document I use to recover the armserver software...but first I recommend you run command:
arraydsp -a
and look at "the following warnings exist" information to be sure there is nothing else listed besides the Log Full condition.
Next refer to the attached, particularly the instruction to remove the logfiles and touch LOGCATLG file. This should clear the log full condition.
NOTE: Please contact HP hardware support if any of the information is unclear and we can help you get the array back optimal again.
Bert Kamps
Frequent Advisor

Re: Armserver problem

In-Su kim, I made a mistake, it is the HPC5445 model 12H.
But you were right, and i just had to install the newest HP Autoraid patch, and it works perfectly now. Thank you very much for that!!!
The previous admin, forgot the install the autoraid patch so that was the problem :)

Nelson, thanks for the document.

Bert Kamps
Frequent Advisor

Re: Armserver problem

Now i have this new problem :)
I found some mails from Armserver:

Activity log for disk array
on /dev/rdsk/c0t0d0 at SERVER is full.

I did a arraylog -C -c RAIDID, and i got this output:

# ./arraylog -C -c BTDCRAID

Primary Controller = X

Controller X Vendor ID = HP
Controller X Product ID = C5447A
Controller X Firmware = 1D02170114
Controller X Serial Number = R741AD8262331111
Controller Y Vendor ID = HP
Controller Y Product ID = C5447A
Controller Y Firmware = 1D02170114
Controller Y Serial Number = R786AD9371141111
Clearing Controller Logs

So everything looked fine to me..
But when i do a logprint i still get 500 logs...

I also tried to delete the Log-files in /var/opt/hparray/log, but that didn't work either.

Anybody knows how to get rid of this LOG FULL error?

Thanks in advance,

Insu Kim
Honored Contributor

Re: Armserver problem

I look through the manual from the begining to the end.
It says, use "SCSI" command.

Do man scsi_log.
I think that scsi_log is the command which makes Log Full message on the front panel clear.

Gook luck!
Never say "no" first.
Bert Kamps
Frequent Advisor

Re: Armserver problem

I also noticed the SCSI command in my manual of the Hpdiskarray... I checked man scsi_log, but i should be able to clear the log with normal HP tools, like arraylog...
Anyways, i just did a couple times arraylog -C -c RAIDNAME, and restarted the server. Now the errors are gone, and are no more ARMServer errors in syslog!

Greetings & thanks for all the help!