Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

AutoRaid hangs for 10-30 seconds, then restores

SOLVED
Go to solution
Ivan Efimenko
Contributor

AutoRaid hangs for 10-30 seconds, then restores

We have AutoRaid disk massive. Everything works good. But if we copying large amount of data (several hundreds Mb), we getting 'hang' for several seconds. It seems, like it is 'software hang', because Autoraid looks like 'working at normal condition'. Also, this problem occurs with Oracle working with massive data.
How we can eliminate this problem?
2 REPLIES
Patrick Wallek
Honored Contributor

Re: AutoRaid hangs for 10-30 seconds, then restores

One thing I would do is call HP and make sure that your 12H has the latest version of the firmware installed. I'm not saying it is definitely a firmware issue, but it could be.
Bill McNAMARA_2
Occasional Advisor
Solution

Re: AutoRaid hangs for 10-30 seconds, then restores

Run arraydsp -i
get the serial number of the autoraid

arraydsp -a
send it to me (wmcn@ireland.com)

make sure that lvm (strings /etc/lvmtab)
is configured well for your VG/LV
ie striped lv across both controllers.

The autoraid can get messed up when detecting
large synchronous writes. It thinks writing into
RAID 5 is better. This is why it's slow.
You can fix your problem temporarily by
creating a big lun and then deleting it (true ha!)

Or: setting the write working set to a low level.
Search for Autoraid understanding the write working
set from hp.com you'll get it eventually.

If you send me the arraydsp -a I'll give you the
command line!

Also for completeness,
logprint > /tmp/text
and send that too
Later,
Bill