Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

BE 8.6 StorageWorks SAN problem

Ayman Altounji
Valued Contributor

BE 8.6 StorageWorks SAN problem

Hi all
I hope someone can help solving the following problem:

We are having problem with Backup Exec 8.6 build 3878 with
Shared Storage Option Connected in SAN configuration based on
Compaq hardware.

We have 2 SAN connected StorageWorks boxes with 8 servers
connected to them through 2 Compaq SAN switches.
Each Server has 2 HBA the latest Compaq SAN software
from the StorageWorks 8.6 kit, including Secure Path 3.1a SP1

Backup device TL895 library connected to the SAN through
a MDR (Modular Data Router).

After being dealing with lot of different problems and
no reliable backup for some time, it was decided to upgrade all
firmware, drivers and SAN software to the newest Compaq /
Veritas supported versions to try to fix the problem.

But after upgrading we still get some errors:
When a server is reboted and its connections are monitored
on the SAN switces one of the HBA gives 3 messages when connecting to the SAN, but the other HBA that is connected
to the same SAN switch as the MDR gives 6 messages
and there is a time out error in the event log for that HBA.

Win 2K System Event log:

Event Type: Error
Event Source: CPQKGPSA
Event Category: None
Event ID: 9
Date: 12.11.2001
Time: 06:09:47
User: N/A
Computer: A01SNMP1
Description:
The device, \Device\Scsi\CPQKGPSA2, did not respond within the timeout period.

Data:
0000: 0f 00 10 00 01 00 6a 00 ......j.
0008: 00 00 00 00 09 00 04 c0 .......?
0010: 01 01 00 50 00 00 00 00 ...P....
0018: 01 00 00 00 00 00 00 00 ........
0020: 00 00 00 00 00 00 00 00 ........
0028: 01 00 00 00 04 00 00 00 ........
0030: 00 00 00 00 07 00 00 00 ........

If the connection to the MDR is disconnected then there are no
errors. If the MDR is reconnected then every host that is onnected to that SAN Switch get these timeout errors.

On the SAN Switch console the errors look like:
Nov 11 22:15:14.716 port 1: PLOGI s_id=0x614100
d_id=0xfffffc cos=0xc df_size=2048

Nov 11 22:15:25.666 port 1: FLOGI 0x614100
cos=0xc bb_credit=64 df_size=2048 cf=0x8000 ........

Detailed configuration 12 nov. 2001

? The HSG80 firmware version, all 4 controllers the same.

HSG80 Software V85P-0, Hardware E1
ALLOCATION_CLASS = 0
SCSI_VERSION = SCSI-2

? KGPSA 8000 firmware version 3.81a1,

? KGPSA 7000 firmware version 2.20x2,

? KGPSA Driver version 5-4.52a9,

Registry settings for the KGPSA driver = RetryIoTimeOut=1;RetryInterval=52;enabledpc=1;queuetarget=1;
queuedepth=15;Topology=1;ScanDown=1;NodeTimeout=10;
LinkTimeOut=40;HLinkTimeOut=5;ElsRetryCount=6;
EmulexOption=64;SimulateDevice=0

? SecurePath 3.1A sp1

? Loop or Fabric ?
Fabric, confirmed by checking the switches

? if Fabric: switch firmware version
Compaq SAN Switch 2.1.9m, (4/11),
Both switches using default configuration (configdefault)

? if Fabric: do you do zoning?
NO ther is no soning in use

? How many servers in your SAN
8 total (Win2k SP2)

? How many RAID boxes in your SAN?
2, one RA12000 and one MA12000
Both in multibus failover mode and DRM enabled

? MDR firmware 1180,

? TL895 firmware Robot 2.40r, Gui 1.23, Drive v97 ,

Thanks in advance
Heidar Gudnason
heidarg@itn.is
1 REPLY
Ayman Altounji
Valued Contributor

Re: BE 8.6 StorageWorks SAN problem

Hi all
After upgrading all firmware, drivers and software that is supported by Compaq (12. Nov. 2001)there was some errors coming from the Data Modular Router (DRM) seen at the San switches. Compaq support personal found out after some digging that the Fiber module in the DMR was faulty. After replacing this Fiber module in the DMR we got our system up and running again.
Regards
Heidar Gudnason
heidarg@itn.is