Disk Enclosures

Command View EVA 9.3 problem

 

Command View EVA 9.3 problem

Hi,

I installed Command View EVA 9.3 as a clean install. Previously I had 9.1 which worked fine.

After installing and trying to log in to CVE I get the following error:
""Login failed. Security services not available. Ensure security services are running.""

I have added the local user to the hp storage admins group, so that is not the issue.

If I look on the xfinstall.log it says:
""
Starting installation of XF

XFROOT is C:\Program Files\Hewlett-Packard\XFROOT
Checking if files from a previously installed version of XF are present

The directory specified by the XFROOT environment variable (currently C:\Program Files\Hewlett-Packard\XFROOT) exists from a previous installation.

Installing XF as a service
XF installed
Starting the XF Service
The HP MIF service is starting......................................
The HP MIF service could not be started.

More help is available by typing NET HELPMSG 3523.

XF Service did not start correctly
Aborting the installation.
Done
""

If I try to start the HP MIF service manually, it says:

""
The HP MIF service on Local Computer started and then stopped. Some services stop automatically if they have no work to do.
""

So I guess the problem is that HP MIF service failed to start and therefore the XF service cannot be installed.

Any help would be appriciated!

Thanks!
11 REPLIES 11
Sivaramakrishna_1
Honored Contributor

Re: Command View EVA 9.3 problem

Hi,

This issue comes if the system is not having any valid IP address and DNS.

Make sure that you connected Network cable to Interface and assign one Valid IP address.

If the system is not haveing any DNS entry, make the Entry with host name in C:\windows\system32\drivers\etc\hosts file

Restart the system and it will work.

Re: Command View EVA 9.3 problem

This server is a member of AD so it has a valid IP address and DNS. It has 4 network interfaces of which two are in different c-classes.

The two other interfaces has tcp/ip disabled and they operate as network interfaces for some microsoft virtual server machines.

kpc2011
New Member

Re: Command View EVA 9.3 problem

Hello,
ich have the same/similar problem.
After installing CV EVA 9.3, the HP MIF Service wont start.
First it says "starting". Then, after 5 minutes or so, it stops. I have an error Message in the windows event log that says that HP MIF Service couldnt be started.

i entered the hostname in the "hosts" file. And re-booted the management server.
Now the service give me the message:

The HP MIF service on Local Computer started and then stopped. Some services stop automatically if they have no work to do.

I hope there is someone who can help.

Alexander Wissfeld
New Member

Re: Command View EVA 9.3 problem

I don't know whether this has been resolved, but we've had to find another solution.

We also had the problem on a clean install that we could not login and after a reboot the MIF service didn't start.

Uninstalling did not work and this one had nothing to do with IPs / DNS / Network Cards.

After some tedious troubleshooting in our case the ACLs for the XFROOT Path (see the environment variables) have somehow gone to hell.

Resetting the folder security (C:\Program Files (x86)\Hewlett-Packard\XFROOT) to "Inherit all" did the trick for us, maybe it works for you as well.
kpc2011
New Member

Re: Command View EVA 9.3 problem

Hi all,

YES. Thats the solution. We now figured it out by ourselfs.
When you do a clean install of CV EVA 9.3 the HP MIF Service wont start after the first re-boot.

Then you have to do the following:

After the first re-boot go to program directory of the XF Program.
Normally

C:\Program Files\Hewlett-Packard\XF

then run the uninstall.bat file

after that right-click to the XFROOT Directory. Normally found at:
C:\Program Files\Hewlett-Packard\XFROOT

go to the security settings tap. You will see that all security and user rights have gone to hell as Alex already mentioned :)).
You have to set them manualy for the whole directory and all sub-folders.

After that, delete the whole XFROOT Directory.

Then go to C:\Program Files\Hewlett-Packard\XF again.

then run install.bat "C:\Program Files\Hewlett-Packard\XFROOT"

After that the MIF Service starts up normally ! And you cann now access the CV EVA Interface.

CV EVA: https://[IP-Adress]:2372
MIF Service: https://[IP Adress]:2374

Wow. Thats really a bug in the software i think.....

Jgade
Occasional Visitor

Re: Command View EVA 9.3 problem

Hi, this issue exist in CV 9.4 as well. Unfornately there is no "uninstall.bat" ...

any suggestions?

 

 

Frantisek Papousek
Regular Visitor

Re: Command View EVA 9.3 problem

For me helped this in CV 9.4 :

setting correct permissions on XFROOT

then

in XF\bin\win-32

run xf.exe -i -ar

then net start xf

CV is running ...

There is no one HP storrage sw install without problems ...

OkekeC
New Member

Re: Command View EVA 9.3 problem

I resolved this issue by adding the user to the HP Storage Users group. After this, I was able to log in to Command View EVA. I hope this helps.

Ruben Renders
Frequent Advisor

Re: Command View EVA 9.3 problem

I've encountered this one before.

Check if the HP Management Infrastructure (MIF) is running.

 

Once started, it was solved in my case.

 

Ruben