Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

CommandView 1.08 - connection errors

Don Mallory
Trusted Contributor

CommandView 1.08 - connection errors

Hi there,

We recently added an EVA into our mixture of SANs (2x VA7410's) and with it came the HP OpenView Storage Area Manager.

From the OVSAM node, the OVSAM host agents have been installed. Post that installation, CommandView 1.08 has been installed to allow us to manage and monitor our VA.

An swlist shows:

# Bundle(s):
CMDVIEWSDM 1.08.00 HP StorageWorks Command View VA

# Product(s) not contained in a Bundle:
HPOVSAMAP 03.20.01.0018 hp OpenView storage area manager Applications
HPOVSAMCA 03.20.01.0014 hp OpenView storage area manager Core Applications
HPOVSAMCP 03.20.00.0061 hp OpenView storage area manager Builder Application
HPOVSAMDA 03.20.01.0009 hp OpenView storage area manager HostAgent DIAL
HPOVSAMHA 03.20.01.0019 hp OpenView storage area manager HostAgent Framework
HPOVSAMHB 03.20.03.0003 hp OpenView storage area manager HostAgent HBA Gateway
HPOVSAMJR 1.4.2.6 hp OpenView storage area manager embedded JRE
HPOVSAMLM 03.20.03.0002 hp OpenView storage area manager Allocater Application
HPOVSAMPM 03.20.03.0002 hp OpenView storage area manager Optimizer Application
HPOVSAMSG 03.20.03.0002 hp OpenView storage area manager HostAgent SCSI Gateway

So, after searching the forums to find the reason for the localhost unreachable, the /etc/opt/sanmgr/hostagent/config/access.dat contains the IP addresses for:

127.0.0.1
IP_for_local_node
IP_for_OVSAM_mgmt_station

An ioscan shows all LUNs that are presented, so switch zoning is okay.

Both the system, and the agents (diald, hostwatchdog, etc. - HA_Dial_Stop/art, HA_trigger stop/art, dial_trigger stop/art) have been restarted.

And now I get the following error when doing an armdiscover:

# armdiscover
This could take several minutes ...

Remote discovery failed with status: Error connecting to HostDiscovery.


Any ideas?

Thanks,
Don


3 REPLIES
Marco Hogeveen_1
Trusted Contributor

Re: CommandView 1.08 - connection errors

You could try this:

Stop HA_trigger daemon in /opt/sanmgr/hostagent/sbin

./HA_trigger stop

Change directories to # /opt/sanmgr/commandview/server/data/DeviceDBFile

remove DeviceDBFile (or rename it to .old just to be sure)

# rm DeviceDBFile

Start HA_trigger daemon

./HA_trigger start

Run armdiscover again. This should resolve the issue

Marco
Don Mallory
Trusted Contributor

Re: CommandView 1.08 - connection errors

I ended up with HP backline support. After 202.5 minutes on the phone we finally found the problems.

There were competing versions of Java installed on the same machine in different paths.

For Commandview an nkthread of 1024 and a max_thread of 256 are a minimum requirement. (to allow enough Java processes to run).

With the OV SAM agents installed, to put the proper version of Java in, everything needed to be swremove'd followed by installing the OV SAM agents, then the Commandview 1.08.03 install.

Two patches were required:
- PHCO_30544 - s700_800 11.11 Pthread enhancement and fixes
- PHSS_30970 - s700_800 11.11 ld(1) and linker tools cumulative patch

That about sums it up.


Don Mallory
Trusted Contributor

Re: CommandView 1.08 - connection errors

Closed off.. see above..