Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

DL320 G4 Sata drives and Raid 1

edmund_6
Advisor

DL320 G4 Sata drives and Raid 1

hi there

Any help would be much appreciated.spent a few hrs on google but still cant get this going.

Background

New Prolient DL320 G4 series rack mount.
2 X sata drives (80G)

Now i want to set up Raid 1.
Ive enable embedded raid in bios and created an array to include the 2 disks and set it to raid 1 ( only 2 slot in the server so only option is raid 0 or 1)
Array built overnight and completed.Restarted and bios picked it up happily. and said it was raid 1.
Now because smart start does not support Sata i booted straight of the OS cd (w2k3)
and f6 with the drivers for the contoller in this case its a 82891GR sata raid.
Windows pickes it up and copies files.
Accept aggrement and then it asks where u want to install windows.Its at this part where it picks up 2 disk instead of one.
(being mirriored it should only pick up one..right ??)
So this didnt look right..
Ive flashed bioses and update rompaqs to the latest but still get this 2 disk option.
Giving up i thought well maybe its just displays it as two disk but it is really raid 1.So i installed right to the end.
Checked in disk manager after windows is installed and it wasnt raided it picked up 2 separated disk.Installed matix storage manager (ACU for HP) and it picked it up as two single disk ..no mirrior.

For a final test i booted with just one disk as a test and bif it was mirrored then it should boot up fine right...and dat failed

So in summary.The bios sees the disk as mirriored but the OS doesnt...

Any ideas....

cheers
Edmund
2 REPLIES
raadek
Honored Contributor

Re: DL320 G4 Sata drives and Raid 1

Edmund,

Yes, lovely embedded hardware/software RAID -always some trouble...

Please have a look a the discussion there:
http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=1026238

You have the same Intel E7230 Chipset, so some posts may be helpful.

I think Louis Vézina was the closest one to the right answer.

Rgds.
Don't panic! [THGTTG]
edmund_6
Advisor

Re: DL320 G4 Sata drives and Raid 1

Thanks Raadek for the reply.I might have finally sussed it though.
anyways here where i got to.
On startup it identifies the controller as a ICH7R.So i was trying the drivers off the intel site, using the driver of intel site it allowed me to install windows but not allow me to raid 1 the config.
Aso when i ran the chip set check util of intel it couldnt identify the chipset.
So i went back to the HP site and tried the adaptec embedded sata driver.
It installed first time round but when it restarted it failed to start with an error... forgot what the error was sorry.
Anyway i redid the installs and when i f6 i specified both the intel 82801GR as well as the hp embedded.And now its seems to be going alright.Very weird i must say but got there eventually.not gd though..i would choose scsi over sata any day...

cheers
edmund