Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

Disk Mounting Problem in VxVM

Disk Mounting Problem in VxVM

Hello Everybody,
I have a setup of a few HP9000 2-4 CPU servers with HP-UX-11i v1. An EVA-3000 has been connected to it through dual SAN switches. Now i want to add one more storage array. I added a third party storage array and created one LUN and presented to the servers for testing. Now the disk is being detected by the server. but two nos. of disks are being detected. That is because of multiple paths to the array i believe. So i masked one paths through VxVM. But i am unable to initialize that disk and i cant mount it then. In VxVM disk list, the disk is shown as "Online Invalid". And the detailed description is as below:
Device: c17t0d0
devicetag: c17t0d0
type: simple
flags: online ready private autoconfig invalid
pubpaths: block=/dev/vx/dmp/c17t0d0 char=/dev/vx/rdmp/c17t0d0
Multipathing information:
numpaths: 1
c17t0d0 state=enabled

I have tried removing any header if its there by vxdisksetup -C option. but still initialization gives error saying invalid disk or disk not present.
Plz help...

Thanks in advance.

Piyush.
4 REPLIES
Thayanidhi
Honored Contributor

Re: Disk Mounting Problem in VxVM

What kind of "third party array" you added?
Is it supported by hp-ux?
Did you check whether you can mix with EVA3K?
Zone config in SAN fabric!!

I strongly feel, the array you are using is not suported (or configured).

Problem only in VxVM.
Is LVM ok? (pvcreate, vgcreate...)

To increase the storage either add more disks (with necessary enclosers) to existing EVA. Or you can add another EVA and zone it properly in SAN fabric.

May be you already thought of all these! Just my openion.

Regds
TT
Attitude (not aptitude) determines altitude.

Re: Disk Mounting Problem in VxVM

I was testing if it works or not. Now how can i check the compatibility. The storage is from HCL-Infiniti series.
LVM is also not able to mount it. no zoning has been configured. and the configuration from the storage side it alright. I need to know that in what condition VxVM shows such message? Can there be some other issue?? and how can i check whether it is compatible or not. If u say that i should check the documentaion, then it wont help, coz the storage is not from a worldwide reknowned vendor.

Thanks.

Piyush.
Suraj Singh_1
Trusted Contributor

Re: Disk Mounting Problem in VxVM

Hi,

1. Do you see the disk in 'ioscan -fnC disk'?
2. If yes, run 'vxdisk scandisks'.
3. run vxdiskadd c17t0d0

This should add the disk to the VxVM control.

Regards
What we cannot speak about we must pass over in silence.

Re: Disk Mounting Problem in VxVM

Dear Suraj,

I have already tried this. In fact VxVM is also detecting the disk. the disk is shown in 'vxdiskadm --> list' as online invalid. and the detailed description with flag is given above.

thanks anyway.

Piyush.