Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

EVA4000 LUN cannot delete directories

SOLVED
Go to solution
jpmartin
Regular Advisor

EVA4000 LUN cannot delete directories

Hi,

a strange problem on EVA4000 XCS 6.0 with servers W2K3-R2 connected on it,

The servers are using the LUNs without problems on R/W access, but it is not possible to delete the directories, the popup message is :

Cannot delete 'directory': access is denied

Deleting other files is OK

The problem is reproducible on another site with the same version.

Any ideas ?

In attachment a problem screen

Regards

Jean-Pierre

8 REPLIES
Uwe Zessin
Honored Contributor

Re: EVA4000 LUN cannot delete directories

I don't think this has anything to do with the EVA. I do see similar messages on my Windows XP-based notebook and it does not use an EVA ;-)

It is possible that some file within the folder hierarchy is in use by an application or a virus scanner or it is a protection problem (even the Administrator cannot always delete all files).

I would check the eventlog anyway...
.
Aneesh Mohan
Honored Contributor

Re: EVA4000 LUN cannot delete directories

Hi ,

100% its not related to EVA ,it could be the directory is using by some application/user or permission issue.

Thanks,
Aneesh
CEF
Occasional Advisor

Re: EVA4000 LUN cannot delete directories

Hello,

our environment has more than 30 x Blade BL20 G4 Servers with Windows 2003 Standard and Enterprise. The problem exists on ALL servers. The strange thing is, that you can delete FILES, but no FOLDERS.

And there is difference. If you create the partition, you can choose between assigning a letter, or mounting the VDISK to a drive/folder. No problem occurs when a letter will be assigned. The problem happens only, when a folder will be mount, as you can see on the attached picture.

I've already checked the user rights and other security things, but it seems everything is okay.

Maybe any other idea?

kind regards,

Sascha Dages

Uwe Zessin
Honored Contributor

Re: EVA4000 LUN cannot delete directories

So you have a problem deleting a folder like:
E:\data\abc\

?
.
CEF
Occasional Advisor

Re: EVA4000 LUN cannot delete directories

Correct!!

CEF
Occasional Advisor
Solution

Re: EVA4000 LUN cannot delete directories

Okay, i've solved the problem.

The problem is the "recycle bin". It's working fine, if you deactive the recycle bin, that the files will be deleted immediately. Then you can delete the folder without any probs.

Thank's for your comments, now i can close the ticket from HP as well.

jpmartin
Regular Advisor

Re: EVA4000 LUN cannot delete directories

So, when the problem occurs whih explorer, it is even possible to delete from rmdir Dos command, see Microsoft article :

http://support.microsoft.com/kb/165126
jpmartin
Regular Advisor

Re: EVA4000 LUN cannot delete directories

N/A