Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

Error deleting DR Group on EVA8100

DJMC
Regular Advisor

Error deleting DR Group on EVA8100

Hi,
Has anyone seen the following error before? I am trying to delete a redundancy group which failed during creation with an error saying there was not enough storage capacity. When I try to delete the group I get this error...


Operation failed!


Invalid object condition for this command.



(Caution: Do not use the Back button to exit this page. Doing so may duplicate the action that produced this page.)


8 REPLIES
Víctor Cespón
Honored Contributor

Re: Error deleting DR Group on EVA8100

Wait a little and try again.
If you get the same error, try to delete it using SSSU, for example:

DELETE DR_GROUP "\Data Replication\payroll"
Marcin.Trzyna
Occasional Advisor

Re: Error deleting DR Group on EVA8100

I have the same problem - an orphaned DR group that can not be deleted. The solution suggested by vcespon does not work - deleting the DR group using SSSU gives the same error:

Error: Error cannot delete object. [Invalid object condition for this command.]

Has anyone got any clue?
Greybeard
Esteemed Contributor

Re: Error deleting DR Group on EVA8100

don't know for sure but it may not have enough space in the DG for the operation now, what's the group's ocupancy like? You could try reducing the protection level and/or deleting any containers temporarily. Of course there is always the good old reboot if the downtime is available, that seems to sort out some of the odd behaviour these units sometimes present.
_________________________________________________
How to assign points on this new forum? Click the Kudos Star!
Rampy(Venu)
Frequent Advisor

Re: Error deleting DR Group on EVA8100

Try this:--
1. Suspend the working DR Groups

2. Disconnect the DR link (Either disable the DR Link port or zone out)

3. Do a failover for the DR group to be deleted from destination EVA

4. Delete the DR group and delete the vdisk if required

5. Enable the DR link and resume the working DR groups.

Otherwise as larry said we have to try resync the controller's on the destination site to resolve this.LEt us know how it goes.If these doesnot resolve then let us know the CVEVA version and details.
Marcin.Trzyna
Occasional Advisor

Re: Error deleting DR Group on EVA8100

We have plenty of unallocated space in a disk group. Both arrays are EVA8100 with XCS 6.110.

I think the steps 2 and 3 in Rampy's procedure need to be reversed, as it would not be possible to fail over the DR group if both sides could not communicate.

In our case it was not possible to fail over the DR group, because it's been in a state of logging the transactions; moreover - it was hang in some way - I did not write that all the problems begun from stalling access to the vdisk belonging to this DR group. We have been trying quite a lot actions, including removing DR groups while EVAs were separated. Finally we managed to remove the DR group at the destination side and than we were able to present vdisks (i.e. replicas) to the host. However, after this operation the remaining DR group at the source side is in a state that it knows about it's peer DR group at the destination EVA, which does not exist anymore... If we try to perform 'Remove Member' action from the vdisk level, we get "Unable to find DR Group on remote storage system" error. When we try to delete the whole DR group, we get "Invalid object condition for this command" error.

As we really wanted to get rid of this erratic condition, we restared controllers one by one on both arrays and it did not help. We also were instructed by the HP service to perform a resync operation on both arrays and this also did not resolve the problem.

I think that at this moment the only resort would be to force some delete operation at the controller level and this would have to be performed by sending the commands directly to the controllers, not by regular users' Command View interface.
Talin
Established Member

Re: Error deleting DR Group on EVA8100

I have the same problem in a 2*EVA6000 CA setup. EVA1 rebootet cause some kind of UPS problem and when it started again it said corrupt quorum disk and the EVA could not start :( HP said to reinizialise the EVA and that worked.
But the working EVA2 still has all the CA setup which is a problem, cause we can't delete this part of the setup cause of the same error as mentioned above. And the destination CA disks all says state unknown.

Any1 know how to force remove dr member disks from DR groups, or force remove all the CA setup from a working EVA leaving all source disks intact??
Solo74
Occasional Visitor

Re: Error deleting DR Group on EVA8100

we have same issue with eva4400 - 6100 replication group, anyone got solution?

Siva_HP
HPE Pro

Re: Error deleting DR Group on EVA8100

Hi, I hope the Target(DR Side) LUNs are in unpresented condition. This is required to delete the DR Group.

 

Else we can also disable the Link between DC and DR sites so that all DGs will be marked as "Failed"

 

At this stage we can delete the DR group but need to delete at both DC and DR sites.

 

Recently we deleted around 8 DR groups in same ways and found no issues.. Enabled the Link after deleting the DR groups which will bring the DR groups normal state..

I work for HP