Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

HDD not rebuilding, ML570 G2 array 6400

Taj jundi
Occasional Contributor

HDD not rebuilding, ML570 G2 array 6400

Hello,

I have ML570 G2, Smart array 6400 and two array.
Windows server 2000 is installed in it.

A 72.8 GB 10k HDD got faulty in Array B, i replaced the HDD but the problem is it doesn't rebuild and in ACU Show physical drives view i can see the HDD but not in Array B nor Array A.

I have updated firmware to version 8.0 as mentioned in the site as well as PSP from SSCD version 8.1.

Anyway the problem seems that the HDD that is installed is not getting the right SCSI ID as in the array the faulty SCSI ID is 6 and the new HDD is getting SCSI ID 2.

I have tried to reboot the server and go to array configuration from post (F8) and check the status, in SCSI ID 6 for array B i get the status as Missing and can't see the HDD i installed at all.

i have tried to install another HDD and still the same problem.

and after i have updated PSP and Firmware it by it self created a new array for the HDD i added which is really strange.

About the led activity, there is no leds at all.

What do you think the problem is
2 REPLIES
Víctor Cespón
Honored Contributor

Re: HDD not rebuilding, ML570 G2 array 6400

Yet another case of RIS corruption

The failed disk is the third one from below?
SCSI IDs are assigned by the hot-plug cage and are fixed. The data on the RAID got corrupted (a single bit, changing a 2 to a 6), and now the controller thinks the arrays should contain a drive with SCSI ID 6. As this disk does noy exist, controller shows the disk as missing.
When you replace the disk, it gets ID 2, not 6, so the controller is still waiting for the disk to be replaced.

Taj jundi
Occasional Contributor

Re: HDD not rebuilding, ML570 G2 array 6400

Well your reply is almost the exact description of my problem.

Whenever i replace the HDD, it doesn't get the the right SCSI ID,i had contacted HP and from ADU Report they told that there is a miss match in the array configurations of array B the one which had the problem, and they said the only thing to solve it is to recreate the array, but another problem occurred, when we create a new array it doesn't get the proper array #, as it's supposed to be Array B, but whenever we create a new array it gets array A and system could not boot unless we remove all the HDD.

eventually i created two more arrays, so i got array 1, 2 and 3 where number 2 is the bootable one, deleted number 1 and number 2 booted again since it has the lesser value.

but again the new array still had problems with rebuilding i eventually decided that maybe array A is affecting any new array i'm creating and had to delete the Array A (the OS) and install it from scratch.

Hope this would be helpfull for who could get such an issue because i didn't find anything in the internet regarding this issue and it was really frustrating.

regards