Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

Hitachi TrueCopy paircreate EX_CMDRJE

dr_gsb
Occasional Visitor

Hitachi TrueCopy paircreate EX_CMDRJE

Hi all,
I am trying to establish replication of Hitachi luns using TrueCopy. I have masked only the Command Device to the management server. The production hosts are seeing the data luns. I changed the "Raid Manager protect" flag to "Disabled" for this.
I am able to see the status of the luns using pairdisplay:
C:\HORCM\etc>pairdisplay -g htc1
Group PairVol(L/R) (Port#,TID, LU),Seq#,LDEV#.P/S,Status,Fence,Seq#,P-LDEV# M
htc1 htc1_000(L) (CL2-B , 1, 327) 5214 327.SMPL ---- ------,----- ----- -
htc1 htc1_000(R) (CL2-B , 1, 232) 8147 232.SMPL ---- ------,----- ----- -
htc1 htc1_001(L) (CL2-B , 1, 328) 5214 328.SMPL ---- ------,----- ----- -
htc1 htc1_001(R) (CL2-B , 1, 233) 8147 233.SMPL ---- ------,----- ----- -
htc1 htc1_002(L) (CL2-B , 1, 329) 5214 329.SMPL ---- ------,----- ----- -
htc1 htc1_002(R) (CL2-B , 1, 234) 8147 234.SMPL ---- ------,----- ----- -

But when I issue paircreate, it fails with an error:
C:\HORCM\etc>paircreate -g htc1 -vl -f data
paircreate: [EX_CMDRJE] An order to the control/command device was rejected
Refer to the command log(C:\HORCM\log2\horcc_vcslx087vm1_log.txt) for details.
It was rejected due to SKEY=0x05, ASC=0x95, SSB=0x8400,0x0032 on Serial#(5214)

The log doesn't contain much info:
CMDLINE : paircreate -g htc1 -vl -f data
11:43:47-dac00-02920- ERROR:cm_sndrcv[rc < 0 from HORCM]
11:43:47-dac00-02920- [paircreate] L_CMD(CREATEPAIR) ERROR :rc = -35
11:43:47-dac00-02920- [paircreate][exit(221)]
[EX_CMDRJE] An order to the control/command device was rejected
[Cause ]: An order to the command(control) device failed,or was rejected.
[Action]:Please confirm the following items.If this trouble doesn't resolve,then collect HORCM error logs(HORCM_LOG=C:\HORCM\log2\curlog) and Remote HORCM logs,and send them to service personnel.
(1) Check if the 'HORC or HOMRCF function' is installed in the RAID.
(2) Check if the RCP and LCP are installed in the RAID.
(3) Check if the path between the RAID CUs is established by using the SVP.
(4) Check if the pair target volume is an appropriate status.

I've checked that the 4 items listed above are satisfied.

Can someone help me here?

Thanks in adv
--gsb
6 REPLIES
whiz_kid911
Frequent Advisor

Re: Hitachi TrueCopy paircreate EX_CMDRJE

could you post the horcm files contents.
also make sure ur not over-subscribing the CA license if its not unlimited.
dr_gsb
Occasional Visitor

Re: Hitachi TrueCopy paircreate EX_CMDRJE

I have hand edited the conf file since the mgmt server doesn't see other data luns.

# Created by mkconf on Fri Oct 29 19:02:40

HORCM_MON
#ip_address service poll(10ms) timeout(10ms)
10.209.73.143 52323 1000 3000

HORCM_CMD
#dev_name dev_name dev_name
#UnitID 0 (Serial# 5214)
\\.\PhysicalDrive2

# ERROR [CMDDEV] Harddisk1 SER = 5214 LDEV = 1 [ DF600F-CM ]
HORCM_DEV
#dev_group dev_name port# TargetID LU# MU#
htc1 htc1_000 CL2-B 1 327
htc1 htc1_001 CL2-B 1 328
htc1 htc1_002 CL2-B 1 329

HORCM_INST
#dev_group ip_address service
htc1 10.209.73.141 52323

Also, attached is a screenshot of the licenses installed on the array.
dr_gsb
Occasional Visitor

Re: Hitachi TrueCopy paircreate EX_CMDRJE

I now even masked the data luns to the mgmt server. But paircreate returns the same error.

--gsb
dr_gsb
Occasional Visitor

Re: Hitachi TrueCopy paircreate EX_CMDRJE

Btw, both the hosts involved (mgmt servers) are Virtual Machines on Vmware ESX 4.0.
The Command devices and the data luns are shown as Raw Device Mappings to the VMs.

--gsb
The Brit
Honored Contributor

Re: Hitachi TrueCopy paircreate EX_CMDRJE


Are the Remote devices presented to a host group? They need to be iirc. I have a dummy group we use for some of this stuff, with no wwn's assigned to it.

Dave.
dr_gsb
Occasional Visitor

Re: Hitachi TrueCopy paircreate EX_CMDRJE

I used a different (old) lun in the horcm conf file and it worked!
It still doesn't work with the new luns that I had just created and added in the conf file.

All the luns are already part of some host port group. I didn't understand what you meant by 'iirc'?

--gsb