Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

IBM Shark Array

SOLVED
Go to solution
Tim Medford
Valued Contributor

IBM Shark Array

Never thought I'd be trying to figure this out, but I know there are a few Shark users out there...so here goes.

I have an L3000 running HPUX 11.0. We've installed 2 a5158a Fibre channel cards and hooked it up to the Shark. According to the mainframe guy, all the config is complete on that side, he has created a single 100gb LUN.

I have installed all the hokey IBM software that is supposed to talk to the shark (2105inst script, SDD drivers, essutils, etc.) All applicable patches for Fibre channel, SCSI, etc...etc.. have been installed.

When I run ioscan I cannot see any hardware addresses for disks where the cards are located. The card is installed at hardware address 0/1/0/0 and the device file is /dev/td0. I do not see any additional hardware addresses for IBM disks at those locations.

The cards are reporting all kinds of parse errors in the syslog. Here's what I see in there:

Mar 19 09:21:23 saifprod vmunix: returned by nport ID 0xfffffe. FLOGI/PLOGI Fail Code = 0x9.
Mar 19 09:24:45 saifprod above message repeats 481 times
Mar 19 09:21:23 saifprod vmunix:
Mar 19 09:24:46 saifprod above message repeats 65 times
Mar 19 09:21:23 saifprod vmunix: 0/1/0/0: Fibre Channel Driver detected a parse error in the FLOGI/PLOGI response
Mar 19 09:24:46 saifprod above message repeats 61 times

I would appreciate any suggestions you might have.

TIA,
Tim


3 REPLIES
S.K. Chan
Honored Contributor

Re: IBM Shark Array

The pasing error PLOGI/FLOGI response from a device usually mean..
1- device not properly configured
2- the device sending a non-compliant PLOGI/FLOGI response
I do not IBM shark around to check. First thing to check is .. is the expected device driver configured in the kernel ?

# /usr/lbin/sysadm/get_sysfile > driver-file
# more driver-file

John Payne_2
Honored Contributor
Solution

Re: IBM Shark Array

If your ESS is serving up the disk to you, you should have no problem seeing the disk in the configuration that you have described. (assuming things are working correctly on your side.)

You should try to verify that your cards are installed correctly and have the right drivers in the kernel. If you have Online Diagnostics, you can run xstm and see if you see the cards there and they are happy.

John
Spoon!!!!
Tim Medford
Valued Contributor

Re: IBM Shark Array

Thanks guys, it's working now. The problem was on the Shark side. It had been configured for point-to-point, and needed to be set to aribitrated_loop.

Even though there is no switch in the middle, it's still not considered a ptp connection.

Tim