HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Disk Enclosures
Showing results for 
Search instead for 
Did you mean: 

LUN config on VA7410 system

Go to solution
Geoff Brown
Frequent Advisor

LUN config on VA7410 system

Can anyone offer some advice?
We have second user VA7410,a DS2405, & 15x 73GByte disks, which we want to configure.
From the vfp, dsp -d reports all disks are "Ready/ Not included" (good, but not bound to a LUN?).
Security is disabled, & password default.
When trying to configure LUN's from the vfp, (cfg -L 0 -a 10G -g 1), get a status "Invalid capacity". RAID level set to AUTORAID.
When using "CommandView SDM" from the host, either CLI or cvui to configure LUN's, we get "Array Status, Device not ready", although we can read error logs & other status OK.
Any info would be much appreciated.
Patrick Wallek
Honored Contributor

Re: LUN config on VA7410 system

You first have to include the disks into the array. To do this you need to use the 'armcfg' command.

The syntax will be something like:

# /opt/sanmgr/commandview/client/sbin/armcfg -D JA0/D0 -a array_name

For more information do a:

# man armcfg
Geoff Brown
Frequent Advisor

Re: LUN config on VA7410 system

Thanks for the info.
I tried the include function with the armcfg command. The attention led's flash on all the disks, & I get a return status of "Disk Array. Device is not ready".
One thing that I didn't mention before, is that the vfp prompt is "No Map>". Perhaps this is significant.
Peter Mattei
Honored Contributor

Re: LUN config on VA7410 system

It seems you VA7410 has been powered off for an extended time. This means your controllers have lost all meta and configuration data of the array.
You can revover from that using the "vfprecover" command or start from scratch. This will bring the array to its latest configuration state.
If you build a new environment I would start from scratch!
To do that use the install flow chart http://h200005.www2.hp.com/bc/docs/support/SupportManual/lpg28975/lpg28975.pdf
As reference use the "User and Service Guide" and the "Installation Guide" on the VA manuals page http://h20000.www2.hp.com/bizsupport/TechSupport/DocumentIndex.jsp?contentType=SupportManual&locale=en_US&docIndexId=179911&taskId=101&prodTypeId=12169&prodSeriesId=89018

I love storage
Ricardo Rocha
Valued Contributor

Re: LUN config on VA7410 system


"No map" is surely significant! This means all configuration and data was erased from the VA. To continue you must format the array.

vfpfmt or vfpformat (i can't remember now)

It will ask you to confirm, and you'll have to write "yes" (all the letter, not only "y").

Then you can continue.

Good luck,

"there is this old man who spent so much of his life sleeping that he is able to keep awake for the rest of his years"
Geoff Brown
Frequent Advisor

Re: LUN config on VA7410 system

Thanks to everyone, each answer helped me to understand the situation better.
I had tried "vfp" fmt, & "CommandView" armfmt before, but it was saying device busy, or just resetting the unit.
I had to configure a DS2405 enclosure, & run JBODfmt. Then I configured the VA again, & ran through the install procedure, & managed to get a basic RAID system configured.
Your help is much appreciated.
bob craig_2
Occasional Visitor

Re: LUN config on VA7410 system

I agree with Ricardo about doing the fmt command from the command line to Initilize and format the disk.