Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

MSA 1000 Firmware upgrade from 1.16

Dan Hooper
Occasional Visitor

MSA 1000 Firmware upgrade from 1.16

G'day

Have searched the forums and found that people recommend upgrading the controller in steps even though I can find no HP docs to say if this is required. However I do agree with the suggestion. I have not been able to find any 2.xx or 3.xx firmware to gradually step up to the latest. Any info on where I can get these would be great.

Thanks
4 REPLIES
Andy_Stor
Valued Contributor

Re: MSA 1000 Firmware upgrade from 1.16

Hi Dan,

I tried searching for 2.xx and 3.xx firmwares but unable to locate any, but what I found is that there are no pre req for 4.24, you can check the below link

http://h18000.www1.hp.com/support/files/server/us/revision/5664.html

You can download 4.24 and then upgrade to 4.48 or 5.20, But since we do not have any docs I will suggest you to take Full System Backup and then perform the upgrade as we are really upgrading from a very low version.

Which Operating System are u using and how is the setup???

Andy
Dan Hooper
Occasional Visitor

Re: MSA 1000 Firmware upgrade from 1.16

Thanks very much for that info Andy. I'm running Windows 2003 so this tool should do the trick I have played with it previously to downgrade a controller. I had just never come accross one running such old firmware.

Have you heard of this firmware (1.16) not enabling a CLI prompt as this is the problem I am trying to resolve. I thought upgrading the firmware might be the first step to trying to resolve it but again I have found no info on anyone having this issue.
Andy_Stor
Valued Contributor

Re: MSA 1000 Firmware upgrade from 1.16

thats right Dan few old firmware does not have a CLI and this firmware is one of them you can try other methods of updating the firmware i.e via the bootable ISO image or from the online update.

Andy
Dan Hooper
Occasional Visitor

Re: MSA 1000 Firmware upgrade from 1.16

Thanks again Andy. For anyone that tries to the same thing I upgraded from 1.16 to 1.18 then directly to 4.24 the 4.48 and all was fine. Be aware however some really old controllers can not be upgraded (I also had one of these but had another one I could upgrade which sorted my issues).